summaryrefslogtreecommitdiff
path: root/obsolete-buildroot/make/dropbear_sshd.mk
diff options
context:
space:
mode:
Diffstat (limited to 'obsolete-buildroot/make/dropbear_sshd.mk')
-rw-r--r--obsolete-buildroot/make/dropbear_sshd.mk31
1 files changed, 20 insertions, 11 deletions
diff --git a/obsolete-buildroot/make/dropbear_sshd.mk b/obsolete-buildroot/make/dropbear_sshd.mk
index d694508f92..04f6f066dc 100644
--- a/obsolete-buildroot/make/dropbear_sshd.mk
+++ b/obsolete-buildroot/make/dropbear_sshd.mk
@@ -3,9 +3,9 @@
# dropbear_sshd
#
#############################################################
-DROPBEAR_SSHD_SOURCE:=dropbear-0.41.tar.bz2
+DROPBEAR_SSHD_SOURCE:=dropbear-0.43.tar.bz2
DROPBEAR_SSHD_SITE:=http://matt.ucc.asn.au/dropbear/releases/
-DROPBEAR_SSHD_DIR:=$(BUILD_DIR)/dropbear-0.41
+DROPBEAR_SSHD_DIR:=$(BUILD_DIR)/dropbear-0.43
DROPBEAR_SSHD_CAT:=bzcat
DROPBEAR_SSHD_BINARY:=dropbearmulti
DROPBEAR_SSHD_TARGET_BINARY:=usr/sbin/dropbear
@@ -18,8 +18,6 @@ dropbear_sshd-source: $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE)
$(DROPBEAR_SSHD_DIR)/.unpacked: $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE)
$(DROPBEAR_SSHD_CAT) $(DL_DIR)/$(DROPBEAR_SSHD_SOURCE) | tar -C $(BUILD_DIR) -xvf -
- $(SOURCE_DIR)/patch-kernel.sh $(DROPBEAR_SSHD_DIR) $(SOURCE_DIR) dropbear-*.patch
- $(SED) 's,^/\* #define DROPBEAR_MULTI.*,#define DROPBEAR_MULTI,g' $(DROPBEAR_SSHD_DIR)/options.h
touch $(DROPBEAR_SSHD_DIR)/.unpacked
$(DROPBEAR_SSHD_DIR)/.configured: $(DROPBEAR_SSHD_DIR)/.unpacked
@@ -43,24 +41,35 @@ $(DROPBEAR_SSHD_DIR)/.configured: $(DROPBEAR_SSHD_DIR)/.unpacked
--infodir=/usr/info \
$(DISABLE_NLS) \
--with-shared \
+ \
+ --disable-zlib \
+ --disable-syslog \
+ --disable-lastlog \
+ --disable-utmp \
+ --disable-utmpx \
+ --disable-wtmp \
+ --disable-wtmpx \
+ --disable-loginfunc \
+ --disable-pututline \
+ --disable-pututxline \
);
touch $(DROPBEAR_SSHD_DIR)/.configured
$(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY): $(DROPBEAR_SSHD_DIR)/.configured
$(MAKE) $(TARGET_CONFIGURE_OPTS) LD=$(TARGET_CC) \
- -C $(DROPBEAR_SSHD_DIR) dropbearmulti
+ -C $(DROPBEAR_SSHD_DIR) strip
$(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY): $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY)
#$(MAKE) DESTDIR=$(TARGET_DIR) $(TARGET_CONFIGURE_OPTS) \
# LD=$(TARGET_CC) -C $(DROPBEAR_SSHD_DIR) install
#rm -rf $(TARGET_DIR)/share/locale $(TARGET_DIR)/usr/info \
# $(TARGET_DIR)/usr/man $(TARGET_DIR)/usr/share/doc
- install -d -m 755 $(TARGET_DIR)/usr/sbin
- install -d -m 755 $(TARGET_DIR)/usr/bin
- install -m 755 $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY) \
- $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
- ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearkey
- ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearconvert
+ # install -d -m 755 $(TARGET_DIR)/usr/sbin
+ # install -d -m 755 $(TARGET_DIR)/usr/bin
+ # install -m 755 $(DROPBEAR_SSHD_DIR)/$(DROPBEAR_SSHD_BINARY) \
+ # $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)
+ # ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearkey
+ # ln -sf ../sbin/dropbear $(TARGET_DIR)/usr/bin/dropbearconvert
dropbear_sshd: uclibc zlib $(TARGET_DIR)/$(DROPBEAR_SSHD_TARGET_BINARY)