summaryrefslogtreecommitdiff
path: root/target/linux/sunxi/cortex-a8/profiles
diff options
context:
space:
mode:
authorwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-11-14 23:12:52 +0000
committerwigyori <wigyori@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-11-14 23:12:52 +0000
commit7d7a601c6522a98b3164fb134459a678956531c6 (patch)
tree76658ab5db8672127f7cb73adb2682a83e432727 /target/linux/sunxi/cortex-a8/profiles
parent22bff5f108d20b4d4b3d79fd37d14ece1b1ede03 (diff)
sunxi: rework target
- update kernel to 3.12 - add patches for clocks, i2c, usb, sid, rtc - support common image for A10/A13/A20 - add support for a couple boards - most drivers are configured into the kernel as of now Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38811 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/sunxi/cortex-a8/profiles')
-rw-r--r--target/linux/sunxi/cortex-a8/profiles/100-generic.mk18
-rw-r--r--target/linux/sunxi/cortex-a8/profiles/110-cubieboard.mk14
2 files changed, 0 insertions, 32 deletions
diff --git a/target/linux/sunxi/cortex-a8/profiles/100-generic.mk b/target/linux/sunxi/cortex-a8/profiles/100-generic.mk
deleted file mode 100644
index 272ec815d7..0000000000
--- a/target/linux/sunxi/cortex-a8/profiles/100-generic.mk
+++ /dev/null
@@ -1,18 +0,0 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/Generic
- NAME:=Generic (default)
- PACKAGES:= \
- uboot-envtools
-endef
-
-define Profile/Generic/Description
- Package set compatible with most Allwinner A10, A10s and A13 SoC based boards.
-endef
-
-$(eval $(call Profile,Generic))
diff --git a/target/linux/sunxi/cortex-a8/profiles/110-cubieboard.mk b/target/linux/sunxi/cortex-a8/profiles/110-cubieboard.mk
deleted file mode 100644
index a08a53f4b6..0000000000
--- a/target/linux/sunxi/cortex-a8/profiles/110-cubieboard.mk
+++ /dev/null
@@ -1,14 +0,0 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-define Profile/CUBIEBOARD
- NAME:=Cubieboard
- PACKAGES:= \
- uboot-envtools
-endef
-
-$(eval $(call Profile,CUBIEBOARD))