summaryrefslogtreecommitdiff
path: root/target/linux/realview/image/Makefile
diff options
context:
space:
mode:
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-02-27 00:12:53 +0000
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-02-27 00:12:53 +0000
commit7ed37d7ef48e601c8a6d22fab6980437a47dcc4a (patch)
treea7e31b59d74e09498c418ee912933963a4facda6 /target/linux/realview/image/Makefile
parent4dc455eb28cb9f99abcaf0b8dd32cd1fbf1baf1d (diff)
realview: fix zImage-initramfs installation
We were copying the actual vmlinux-initramfs.elf kernel which cannot be launched by QEMU or a real bootloader, use zImage-initramfs instead. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39756 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/realview/image/Makefile')
-rw-r--r--target/linux/realview/image/Makefile6
1 files changed, 5 insertions, 1 deletions
diff --git a/target/linux/realview/image/Makefile b/target/linux/realview/image/Makefile
index dd0d9ee76d..c6ff8ce46a 100644
--- a/target/linux/realview/image/Makefile
+++ b/target/linux/realview/image/Makefile
@@ -8,7 +8,11 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Image/BuildKernel
- cp $(LINUX_DIR)/arch/$(ARCH)/boot/$(subst ",,$(KERNELNAME)) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+ cp $(KDIR)/$(subst ",,$(KERNELNAME)) $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
+endef
+
+define Image/BuildKernel/Initramfs
+ cp $(KDIR)/$(subst ",,$(KERNELNAME))-initramfs $(BIN_DIR)/openwrt-$(BOARD)-vmlinux-initramfs.elf
endef
define Image/Build/squashfs