summaryrefslogtreecommitdiff
path: root/target/linux/ramips/patches-3.8/105-usb_dwc_otg.patch
diff options
context:
space:
mode:
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-02-25 21:28:42 +0000
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-02-25 21:28:42 +0000
commit749c9b0ead2d055a6c98daa0bdccd5b2f0742170 (patch)
tree0ad66e4e6d4fc521de8768c6b46f12aaaf9b5b93 /target/linux/ramips/patches-3.8/105-usb_dwc_otg.patch
parent47f0450c3bb26bdb4f88ca7227dcad2bbe933df1 (diff)
ramips: add support for 3.8
Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35801 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ramips/patches-3.8/105-usb_dwc_otg.patch')
-rw-r--r--target/linux/ramips/patches-3.8/105-usb_dwc_otg.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/target/linux/ramips/patches-3.8/105-usb_dwc_otg.patch b/target/linux/ramips/patches-3.8/105-usb_dwc_otg.patch
new file mode 100644
index 0000000000..88c211569b
--- /dev/null
+++ b/target/linux/ramips/patches-3.8/105-usb_dwc_otg.patch
@@ -0,0 +1,20 @@
+--- a/drivers/usb/Kconfig
++++ b/drivers/usb/Kconfig
+@@ -188,4 +188,6 @@ source "drivers/usb/gadget/Kconfig"
+
+ source "drivers/usb/otg/Kconfig"
+
++source "drivers/usb/dwc_otg/Kconfig"
++
+ endif # USB_SUPPORT
+--- a/drivers/usb/Makefile
++++ b/drivers/usb/Makefile
+@@ -52,6 +52,8 @@ obj-$(CONFIG_EARLY_PRINTK_DBGP) += early
+ obj-$(CONFIG_USB_ATM) += atm/
+ obj-$(CONFIG_USB_SPEEDTOUCH) += atm/
+
++obj-$(CONFIG_DWC_OTG) += dwc_otg/
++
+ obj-$(CONFIG_USB_MUSB_HDRC) += musb/
+ obj-$(CONFIG_USB_CHIPIDEA) += chipidea/
+ obj-$(CONFIG_USB_RENESAS_USBHS) += renesas_usbhs/