summaryrefslogtreecommitdiff
path: root/target/linux/kirkwood/image
diff options
context:
space:
mode:
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-02-15 23:53:08 +0000
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-02-15 23:53:08 +0000
commit62235c06381c64d7de3ad8187e1566dbba6c0d53 (patch)
treeceea557d97b4a08faf543f696dc839b37c6ad1fd /target/linux/kirkwood/image
parentf08d9c8a10d73abe48f05871fc9558dd47d63733 (diff)
kirkwood: update support for iconnect
Previous patch was pushed due to false user report. While at it fix alphabetic ordering. The board is optimized for ubi(fs) and boots OpenWrt without changes to uboot environment if OpenWrt's uboot package is used. In order to flash the image run following commands in uboot shell: nand erase 0x200000 0x1fe00000 ubi part root ; ubi remove rootfs ; ubi create rootfs tftpboot 0x800000 openwrt-kirkwood-iconnect-rootfs.ubifs ; ubi write 0x800000 rootfs ${filesize} ; reset Signed-off-by: Luka Perkov <luka@openwrt.org> CC: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39591 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/kirkwood/image')
-rw-r--r--target/linux/kirkwood/image/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/kirkwood/image/Makefile b/target/linux/kirkwood/image/Makefile
index 11b28fd58b..d7ace45199 100644
--- a/target/linux/kirkwood/image/Makefile
+++ b/target/linux/kirkwood/image/Makefile
@@ -117,12 +117,12 @@ Image/InstallKernel/Template/Generic=$(call Image/InstallKernel/Template)
Image/BuildKernel/Template/DOCKSTAR=$(call Image/BuildKernel/Template,dockstar)
Image/InstallKernel/Template/DOCKSTAR=$(call Image/InstallKernel/Template,dockstar)
-Image/BuildKernel/Template/ICONNECT=$(call Image/BuildKernel/Template,iconnect)
-Image/InstallKernel/Template/ICONNECT=$(call Image/InstallKernel/Template,iconnect)
-
Image/BuildKernel/Template/IB62X0=$(call Image/BuildKernel/Template,ib62x0)
Image/InstallKernel/Template/IB62X0=$(call Image/InstallKernel/Template,ib62x0)
+Image/BuildKernel/Template/ICONNECT=$(call Image/BuildKernel/Template,iconnect)
+Image/InstallKernel/Template/ICONNECT=$(call Image/InstallKernel/Template,iconnect)
+
Image/BuildKernel/Template/POGOE02=$(call Image/BuildKernel/Template,pogo_e02)
Image/InstallKernel/Template/POGOE02=$(call Image/InstallKernel/Template,pogo_e02)