summaryrefslogtreecommitdiff
path: root/target/linux/brcm63xx/generic/profiles
diff options
context:
space:
mode:
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-02-22 11:16:35 +0000
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-02-22 11:16:35 +0000
commitadee60ad27dd2d90620a57d6b255cc8102a842ea (patch)
treecc4172b2eaddf469b77ca0c1a80e04184d193242 /target/linux/brcm63xx/generic/profiles
parent64fe18d7efedf1dd1db8d9c4dc387b936d3e6bba (diff)
brcm63xx: Add profile and build image for Sagemcom F@ST2704V2 ADSL router
This adds profile and build image for Sagemcom F@st2704, using b43 driver. For WiFi to work properly BCMA fallback SPROM support patch must be applied (http://git.io/z1Ki8A). Signed-off-by: Marcin Jurkowski <marcin1j@gmail.com> Patchwork: http://patchwork.openwrt.org/patch/4212/ Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39673 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/brcm63xx/generic/profiles')
-rw-r--r--target/linux/brcm63xx/generic/profiles/202-Sagemcom.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/generic/profiles/202-Sagemcom.mk b/target/linux/brcm63xx/generic/profiles/202-Sagemcom.mk
new file mode 100644
index 0000000000..ebe1755f09
--- /dev/null
+++ b/target/linux/brcm63xx/generic/profiles/202-Sagemcom.mk
@@ -0,0 +1,16 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Sagemcom-2704V2
+ NAME:=Sagemcom F@ST 2704 V2
+ PACKAGES:=kmod-b43 wpad-mini \
+ kmod-usb2 kmod-usb-ohci kmod-ledtrig-usbdev
+endef
+define Profile/Sagemcom-2704V2/Description
+ Package set optimized for Sagemcom F@ST 2704 using open-source b43 WiFi driver
+endef
+$(eval $(call Profile,Sagemcom-2704V2))