summaryrefslogtreecommitdiff
path: root/target/linux/avr32/image/Makefile
diff options
context:
space:
mode:
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2008-04-28 14:10:09 +0000
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2008-04-28 14:10:09 +0000
commit2f214fab5e6d2f06923e80dbe7ef363909f9cf37 (patch)
treefbfbdc7e0cb6b00c577618049593602d208d1bc0 /target/linux/avr32/image/Makefile
parentfec712ca7014a77a4f9cf2261fcc0d8cb27b53f8 (diff)
enable optional building of u-boot for avr32
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10961 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/avr32/image/Makefile')
-rw-r--r--target/linux/avr32/image/Makefile9
1 files changed, 9 insertions, 0 deletions
diff --git a/target/linux/avr32/image/Makefile b/target/linux/avr32/image/Makefile
index 3568984189..cbaf07dfb3 100644
--- a/target/linux/avr32/image/Makefile
+++ b/target/linux/avr32/image/Makefile
@@ -4,9 +4,18 @@
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
+
include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
+define Build/Clean
+ $(MAKE) -C u-boot clean
+endef
+
+define Build/Compile
+ $(MAKE) -C u-boot compile
+endef
+
define Image/Prepare
cp $(LINUX_DIR)/arch/avr32/boot/images/uImage $(KDIR)/uImage
endef