summaryrefslogtreecommitdiff
path: root/target/linux/ar71xx/image/Makefile
diff options
context:
space:
mode:
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-08-02 09:54:33 +0000
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-08-02 09:54:33 +0000
commit70b3c1262bec05f587d0ea43cbcccd487d0dc46f (patch)
tree9de893250eaaa5a42fd9925ee2680d42ce0db71b /target/linux/ar71xx/image/Makefile
parent58aa6ee58f5b456acf9c5d72f567cd7fdffa1db8 (diff)
ar71xx: image: allow to use board specific code in the lzma-loader
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@32945 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target/linux/ar71xx/image/Makefile')
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 3897dd49bf..26ac0ab102 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -113,7 +113,7 @@ define Image/BuildLoader
-rm -rf $(KDIR)/lzma-loader
$(LOADER_MAKE) LOADER=loader-$(1).$(2) KERNEL_CMDLINE="$(3)"\
LZMA_TEXT_START=0x80a00000 LOADADDR=0x80060000 \
- LOADER_DATA="$(KDIR)/vmlinux.bin.lzma" \
+ LOADER_DATA="$(KDIR)/vmlinux.bin.lzma" BOARD="$(1)" \
compile loader.$(2)
endef
@@ -121,7 +121,7 @@ define Image/BuildLoaderAlone
-rm -rf $(KDIR)/lzma-loader
$(LOADER_MAKE) LOADER=loader-$(1).$(2) KERNEL_CMDLINE="$(3)" \
LZMA_TEXT_START=0x80a00000 LOADADDR=0x80060000 \
- FLASH_OFFS=$(4) FLASH_MAX=$(5) \
+ BOARD="$(1)" FLASH_OFFS=$(4) FLASH_MAX=$(5) \
compile loader.$(2)
endef