summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-07-29 09:38:08 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-07-29 09:38:08 +0000
commitf6ace1b390ed4216edf008a89199b07d8a141e9e (patch)
tree704b5934693f2981ae0ea06abb683ee90ed61a5b /package
parent87687639c98a4ad4356b63b81afaba4a2902374c (diff)
mac80211: add support for verbose builds using V=sc
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37597 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/mac80211/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index a1ea8c24c0..ddf2237ebd 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1299,6 +1299,10 @@ MAKE_OPTS:= -C "$(PKG_BUILD_DIR)" \
KERNEL_SUBLEVEL=$(lastword $(subst ., ,$(KERNEL_PATCHVER))) \
KBUILD_LDFLAGS_MODULE_PREREQ=
+ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
+ MAKE_OPTS += V=1
+endif
+
define ConfigVars
$(subst $(space),,$(foreach opt,$(config-$(1)),CPTCFG_$(opt)=$(1)
))