summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-03-26 09:48:20 +0000
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-03-26 09:48:20 +0000
commitd72acf9ee1c80adc57b157996c1ed205c16bbfd6 (patch)
treef6e8cde93e3a2dbaba0fc6ade9c8289e4259747b /package
parent29219fba112462d22664636dfce1f629586aa970 (diff)
dhcp: send 6rd-ORO when expecting 6rd-information
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40019 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/network/config/netifd/Makefile2
-rwxr-xr-xpackage/network/config/netifd/files/lib/netifd/proto/dhcp.sh1
2 files changed, 2 insertions, 1 deletions
diff --git a/package/network/config/netifd/Makefile b/package/network/config/netifd/Makefile
index 75314f161d..8414ff91b4 100644
--- a/package/network/config/netifd/Makefile
+++ b/package/network/config/netifd/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=netifd
-PKG_VERSION:=2014-03-21
+PKG_VERSION:=2014-03-26
PKG_RELEASE=$(PKG_SOURCE_VERSION)
PKG_SOURCE_PROTO:=git
diff --git a/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh b/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
index 0481d05132..80c3562e69 100755
--- a/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
+++ b/package/network/config/netifd/files/lib/netifd/proto/dhcp.sh
@@ -36,6 +36,7 @@ proto_dhcp_setup() {
[ "$broadcast" = 1 ] && broadcast="-B" || broadcast=
[ -n "$clientid" ] && clientid="-x 0x3d:${clientid//:/}" || clientid="-C"
[ -n "$iface6rd" ] && proto_export "IFACE6RD=$iface6rd"
+ [ -n "$iface6rd" ] && append dhcpopts "-O 212"
[ "$delegate" = "0" ] && proto_export "IFACE6RD_DELEGATE=0"
proto_export "INTERFACE=$config"