summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-09-29 11:26:09 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-09-29 11:26:09 +0000
commit74f8f5360f839552d7b4e749360464755593e270 (patch)
tree431713ee6bbddb6770d0e31d31d727b72eb3af00 /package
parentcd084f48a50847597b76768220f007f7c9724cd0 (diff)
uhttpd: add a config option for using ustream-polarssl, and use it by default
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38250 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/network/services/uhttpd/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/package/network/services/uhttpd/Makefile b/package/network/services/uhttpd/Makefile
index 7c3ea5b055..2ff2ff798c 100644
--- a/package/network/services/uhttpd/Makefile
+++ b/package/network/services/uhttpd/Makefile
@@ -51,7 +51,10 @@ endef
define Package/uhttpd-mod-tls
$(Package/uhttpd/default)
TITLE+= (TLS plugin)
- DEPENDS:=uhttpd +PACKAGE_uhttpd-mod-tls_cyassl:libustream-cyassl +PACKAGE_uhttpd-mod-tls_openssl:libustream-openssl
+ DEPENDS:=uhttpd \
+ +PACKAGE_uhttpd-mod-tls_polarssl:libustream-polarssl \
+ +PACKAGE_uhttpd-mod-tls_cyassl:libustream-cyassl \
+ +PACKAGE_uhttpd-mod-tls_openssl:libustream-openssl
endef
define Package/uhttpd-mod-tls/description
@@ -62,7 +65,10 @@ define Package/uhttpd-mod-tls/config
choice
depends on PACKAGE_uhttpd-mod-tls
prompt "TLS Provider"
- default PACKAGE_uhttpd-mod-tls_cyassl
+ default PACKAGE_uhttpd-mod-tls_polarssl
+
+ config PACKAGE_uhttpd-mod-tls_polarssl
+ bool "PolarSSL"
config PACKAGE_uhttpd-mod-tls_cyassl
bool "CyaSSL"