summaryrefslogtreecommitdiff
path: root/package
diff options
context:
space:
mode:
authorhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-11-17 16:41:40 +0000
committerhauke <hauke@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-11-17 16:41:40 +0000
commit47cfd5b632216ae9757d3a897925955dd1d73c01 (patch)
tree03a8ee8b3d0d31a580fef72b17272f6f60379d99 /package
parent2cd5ca00434a820519c974ebade178b949a949e1 (diff)
kernel: add vmxnet3 module
support VMware ethernet adapters Signed-off-by: Dirk Neukirchen <dirkneukirchen@web.de> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38840 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package')
-rw-r--r--package/kernel/linux/modules/netdevices.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netdevices.mk b/package/kernel/linux/modules/netdevices.mk
index 665aa93b20..dca6f588d3 100644
--- a/package/kernel/linux/modules/netdevices.mk
+++ b/package/kernel/linux/modules/netdevices.mk
@@ -756,3 +756,19 @@ define KernelPackage/gianfar/description
endef
$(eval $(call KernelPackage,gianfar))
+
+
+define KernelPackage/vmxnet3
+ SUBMENU:=$(NETWORK_DEVICES_MENU)
+ TITLE:=VMware VMXNET3 ethernet driver
+ DEPENDS:=@PCI_SUPPORT
+ KCONFIG:=CONFIG_VMXNET3
+ FILES:=$(LINUX_DIR)/drivers/net/vmxnet3/vmxnet3.ko
+ AUTOLOAD:=$(call AutoLoad,35,vmxnet3)
+endef
+
+define KernelPackage/vmxnet3/description
+ Kernel modules for VMware VMXNET3 ethernet adapters.
+endef
+
+$(eval $(call KernelPackage,vmxnet3))