summaryrefslogtreecommitdiff
path: root/package/network/services
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-02-24 15:03:06 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-02-24 15:03:06 +0000
commitca2185dc4be60657a9073c2cb14de0d3f109c41d (patch)
tree718b79d60058da189d3f841f85a789f3a7f98641 /package/network/services
parent1a615a186d20698187bd7af924eb079d637055f7 (diff)
hostapd: link against librt if eglibc is used
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39741 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services')
-rw-r--r--package/network/services/hostapd/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index f00472ac53..7070afd6ef 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -86,6 +86,10 @@ ifneq ($(LOCAL_TYPE),hostapd)
CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
endif
+ifdef CONFIG_USE_EGLIBC
+ TARGET_LDFLAGS += -lrt
+endif
+
DRV_DEPENDS:=+PACKAGE_kmod-mac80211:libnl-tiny @(!TARGET_avr32||BROKEN)
define Package/hostapd/Default