summaryrefslogtreecommitdiff
path: root/package/network/services/hostapd/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-12-02 16:41:03 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-12-02 16:41:03 +0000
commit148b41b2f383f13a23d7a64394924c845838f986 (patch)
tree89cfa70014c554c8753782fab558317974e838ee /package/network/services/hostapd/Makefile
parent2fbe47ce2f32deb281025ec1663e9911f73e8664 (diff)
netifd: add wireless configuration support and port mac80211 to the new framework
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38988 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/network/services/hostapd/Makefile')
-rw-r--r--package/network/services/hostapd/Makefile11
1 files changed, 11 insertions, 0 deletions
diff --git a/package/network/services/hostapd/Makefile b/package/network/services/hostapd/Makefile
index 896a6373bd..05a74bb3b8 100644
--- a/package/network/services/hostapd/Makefile
+++ b/package/network/services/hostapd/Makefile
@@ -208,6 +208,11 @@ define Package/wpa-cli/Description
WPA Supplicant control utility
endef
+define Package/hostapd-common
+ TITLE:=hostapd/wpa_supplicant common support files
+ SECTION:=net
+ CATEGORY:=Network
+endef
ifneq ($(wildcard $(PKG_BUILD_DIR)/.config_*),$(subst .configured_,.config_,$(STAMP_CONFIGURED)))
define Build/Configure/rebuild
@@ -309,6 +314,11 @@ define Install/supplicant
$(INSTALL_DIR) $(1)/usr/sbin
endef
+define Package/hostapd-common/install
+ $(INSTALL_DIR) $(1)/lib/netifd
+ $(INSTALL_DATA) ./files/netifd.sh $(1)/lib/netifd/hostapd.sh
+endef
+
define Package/hostapd/install
$(call Install/hostapd,$(1))
$(INSTALL_BIN) $(PKG_BUILD_DIR)/hostapd/hostapd $(1)/usr/sbin/
@@ -355,3 +365,4 @@ $(eval $(call BuildPackage,wpa-supplicant-mini))
$(eval $(call BuildPackage,wpa-supplicant-p2p))
$(eval $(call BuildPackage,wpa-cli))
$(eval $(call BuildPackage,hostapd-utils))
+$(eval $(call BuildPackage,hostapd-common))