summaryrefslogtreecommitdiff
path: root/package/libs/toolchain/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-03-20 13:51:47 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-03-20 13:51:47 +0000
commit39c71059b506965ee6b8236fafa6f96cfc5b249b (patch)
tree84dcff766727ec1a31c0a14241265ee0eb6a49dc /package/libs/toolchain/Makefile
parent633e3a0c98a4873b4aec21da3394e62a02315958 (diff)
toolchain: add a symlink for musl softfloat ldso to the path where our gcc expects it
Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39966 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/libs/toolchain/Makefile')
-rw-r--r--package/libs/toolchain/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/package/libs/toolchain/Makefile b/package/libs/toolchain/Makefile
index 202e9d095d..a29b3221ec 100644
--- a/package/libs/toolchain/Makefile
+++ b/package/libs/toolchain/Makefile
@@ -428,6 +428,9 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(1)/lib/
endef
+ LD_MUSL_NAME = $(notdir $(firstword $(wildcard $(TOOLCHAIN_DIR)/lib/ld-musl-*.so*)))
+ $(warning LD_MUSL_NAME='$(LD_MUSL_NAME)')
+
define Package/musl/install
$(INSTALL_DIR) $(1)/lib
$(CP) \
@@ -436,6 +439,7 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
$(CP) \
$(TOOLCHAIN_DIR)/lib/libc.so* \
$(1)/lib/
+ $(if $(findstring -sf.so,$(LD_MUSL_NAME)),ln -s $(LD_MUSL_NAME) $(1)/lib/$(subst -sf.so,.so,$(LD_MUSL_NAME)))
endef
define Package/libc/install