summaryrefslogtreecommitdiff
path: root/package/kernel/linux
diff options
context:
space:
mode:
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-03-20 23:15:56 +0000
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-03-20 23:15:56 +0000
commit1fcdc8c4cb0aa7265e6ee8f3b420d22eb40a6918 (patch)
tree0d93822f447af1d79c9ef5f4dcfe620565ae48a6 /package/kernel/linux
parent12c189ae4878013bf3df996ec6b349325eee2979 (diff)
modules: make kmod-pcspkr depend on X86
The kernel Kconfig dependency lists X86, and we will fail building this module on other platforms such as Malta. Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39974 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux')
-rw-r--r--package/kernel/linux/modules/sound.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 777d274a4e..ebdd3d9fe3 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -262,7 +262,7 @@ $(eval $(call KernelPackage,sound-soc-gw_avila))
define KernelPackage/pcspkr
- DEPENDS:=@!TARGET_x86
+ DEPENDS:=@TARGET_x86
TITLE:=PC speaker support
KCONFIG:= \
CONFIG_INPUT_PCSPKR \