summaryrefslogtreecommitdiff
path: root/package/kernel/linux/modules
diff options
context:
space:
mode:
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-25 10:29:49 +0000
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-25 10:29:49 +0000
commit4c73f83ff632e9c1f35aab91aee17dbfd0910c22 (patch)
tree3aefc04c94b134f54a723fea3373ca21a78ae72f /package/kernel/linux/modules
parent303fbc6d6fe42375b04e1cc2a0179f354801b2da (diff)
kernel: add keyboard-imx module
Signed-off-by: Luka Perkov <luka@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38537 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules')
-rw-r--r--package/kernel/linux/modules/input.mk20
1 files changed, 19 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/input.mk b/package/kernel/linux/modules/input.mk
index 421a6b8fca..32adc1ecf4 100644
--- a/package/kernel/linux/modules/input.mk
+++ b/package/kernel/linux/modules/input.mk
@@ -159,7 +159,7 @@ define KernelPackage/input-matrixkmap
KCONFIG:=CONFIG_INPUT_MATRIXKMAP
DEPENDS:=@!LINUX_3_3
FILES:=$(LINUX_DIR)/drivers/input/matrix-keymap.ko
- AUTOLOAD:=$(call AutoLoad,20,matrix-keymap)
+ AUTOLOAD:=$(call AutoProbe,matrix-keymap)
$(call AddDepends/input)
endef
@@ -184,3 +184,21 @@ define KernelPackage/acpi-button/description
endef
$(eval $(call KernelPackage,acpi-button))
+
+
+define KernelPackage/keyboard-imx
+ SUBMENU:=$(INPUT_MODULES_MENU)
+ TITLE:=IMX keypad support
+ DEPENDS:=@(TARGET_mxs||TARGET_imx6) +kmod-input-matrixkmap
+ KCONFIG:= \
+ CONFIG_KEYBOARD_IMX \
+ CONFIG_INPUT_KEYBOARD=y
+ FILES:=$(LINUX_DIR)/drivers/input/keyboard/imx_keypad.ko
+ AUTOLOAD:=$(call AutoProbe,imx_keypad)
+endef
+
+define KernelPackage/keyboard-imx/description
+ Enable support for IMX keypad port.
+endef
+
+$(eval $(call KernelPackage,keyboard-imx))