summaryrefslogtreecommitdiff
path: root/package/kernel/linux/modules/hwmon.mk
diff options
context:
space:
mode:
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-09-10 22:26:30 +0000
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-09-10 22:26:30 +0000
commitf638ab935813921186ad076f615bc1634c741a44 (patch)
treec422e7056ad7b39e5e818b9a41fa5359a352ebfa /package/kernel/linux/modules/hwmon.mk
parent3cf32d404bd036767e7dda7f7d799e7b9a393bbc (diff)
kernel: allow hwmon GSC driver for all targets
- enable using hwmon GSC driver on all targets - add a kmod package for it Signed-off-by: Tim Harvey <tharvey@gateworks.com> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37933 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/linux/modules/hwmon.mk')
-rw-r--r--package/kernel/linux/modules/hwmon.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index 5af311df66..b1f4744330 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -219,3 +219,18 @@ define KernelPacakge/hwmon-w83627hf/description
endef
$(eval $(call KernelPackage,hwmon-w83627hf))
+
+
+define KernelPackage/hwmon-gsc
+ TITLE:=Gateworks GSC monitoring support
+ KCONFIG:=CONFIG_SENSORS_GSC
+ FILES:=$(LINUX_DIR)/drivers/hwmon/gsc.ko
+ AUTOLOAD:=$(call AutoLoad,50,gsc)
+$(call AddDepends/hwmon)
+endef
+
+define KernelPacakge/hwmon-gsc/description
+ Kernel module for the Gateworks System Controller chips.
+endef
+
+$(eval $(call KernelPackage,hwmon-gsc))