summaryrefslogtreecommitdiff
path: root/package/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-03-13 12:12:58 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-03-13 12:12:58 +0000
commitb07e567e6cc425b2293fbc83c187c1558fdf186b (patch)
tree07d6fc0552fea718c9c1017c66159914cba63e6b /package/Makefile
parent4b07676d91294bca0ebafb9424320238c005f302 (diff)
target/sdk: use .config instead of unconditionally enabling all build dirs
Call make defconfig on every build to catch newly added packages Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39913 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/Makefile')
-rw-r--r--package/Makefile7
1 files changed, 2 insertions, 5 deletions
diff --git a/package/Makefile b/package/Makefile
index d46cb2ca0e..3b4eecdf0b 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -10,11 +10,8 @@ curdir:=package
-include $(TMP_DIR)/.packagedeps
$(curdir)/builddirs:=$(sort $(package-) $(package-y) $(package-m))
$(curdir)/builddirs-install:=.
-ifeq ($(SDK),1)
-else
- $(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
- $(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
-endif
+$(curdir)/builddirs-default:=. $(sort $(package-y) $(package-m))
+$(curdir)/builddirs-prereq:=. $(sort $(prereq-y) $(prereq-m))
ifneq ($(IGNORE_ERRORS),)
package-y-filter := $(package-y)
package-m-filter := $(filter-out $(package-y),$(package-m))