summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-23 15:17:15 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-23 15:17:15 +0000
commitcc3851113e1be8a5861af2f20a2e0bce57c0c645 (patch)
tree9b3f73bbc6f658fc746d173c0cf842de0bc53dc4 /openwrt
parentc3671de19ba1fc0f1b5dbe3040fa3387deb7c121 (diff)
add missing pg_config.h header to staging_dir, required to build php5 extension
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1737 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/package/postgresql/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/openwrt/package/postgresql/Makefile b/openwrt/package/postgresql/Makefile
index 1f37bb7527..d83f1afb85 100644
--- a/openwrt/package/postgresql/Makefile
+++ b/openwrt/package/postgresql/Makefile
@@ -97,6 +97,7 @@ $(STAGING_DIR)/usr/lib/libpq.so: $(PKG_BUILD_DIR)/.built
mkdir -p $(STAGING_DIR)/usr/include
cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/libpq-fe.h $(STAGING_DIR)/usr/include/
+ cp -fpR $(PKG_INSTALL_DIR)/usr/include/pg_config.h $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgres_ext.h $(STAGING_DIR)/usr/include/
cp -fpR $(PKG_INSTALL_DIR)/usr/include/postgresql $(STAGING_DIR)/usr/include/
mkdir -p $(STAGING_DIR)/usr/lib
@@ -109,6 +110,7 @@ uninstall-dev:
rm -rf \
$(STAGING_DIR)/usr/include/libpq \
$(STAGING_DIR)/usr/include/libpq-fe.h \
+ $(STAGING_DIR)/usr/include/pg_config.h \
$(STAGING_DIR)/usr/include/postgres_ext.h \
$(STAGING_DIR)/usr/include/postgresql \
$(STAGING_DIR)/usr/lib/libpq.{a,so*} \