summaryrefslogtreecommitdiff
path: root/openwrt
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-06 11:02:08 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-06 11:02:08 +0000
commit7c2693b3bab3be3bf249b80f89f50186443e3244 (patch)
treef9b0ca3e14923dbe46ce73f1e11adb105637375d /openwrt
parent66a6bceea36ea0c94760df574609af7a65dcea73 (diff)
Change ipkg invocation and add -force-defaults option
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@313 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt')
-rw-r--r--openwrt/rules.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/openwrt/rules.mk b/openwrt/rules.mk
index 681d4f9b1c..4218bbf1b2 100644
--- a/openwrt/rules.mk
+++ b/openwrt/rules.mk
@@ -112,7 +112,8 @@ endif
# invoke ipkg with configuration in $(STAGING_DIR)/etc/ipkg.conf
-IPKG := PATH="$(TARGET_PATH)" IPKG_CONF_DIR=$(STAGING_DIR)/etc ipkg -force-depends
+IPKG := IPKG_CONF_DIR=$(STAGING_DIR)/etc $(TARGET_DIR)/bin/ipkg -force-defaults -force-depends
+IPKG_STATE_DIR := $(TARGET_DIR)/usr/lib/ipkg
# invoke ipkg-build with some default options
IPKG_BUILD := PATH="$(TARGET_PATH)" ipkg-build -c -o root -g root