summaryrefslogtreecommitdiff
path: root/openwrt/toolchain/binutils/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-15 18:26:17 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-15 18:26:17 +0000
commit4f7fc3e94c5cde6bf782341ae9f04572c5682134 (patch)
tree34099d19b1d675bded36a11a1560041f9344c3c3 /openwrt/toolchain/binutils/Makefile
parent15096df2835b013c4d45d47da4443fa16721e4a9 (diff)
add new binutils versions
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1684 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/toolchain/binutils/Makefile')
-rw-r--r--openwrt/toolchain/binutils/Makefile26
1 files changed, 12 insertions, 14 deletions
diff --git a/openwrt/toolchain/binutils/Makefile b/openwrt/toolchain/binutils/Makefile
index e3bee5da17..2a1c728dbb 100644
--- a/openwrt/toolchain/binutils/Makefile
+++ b/openwrt/toolchain/binutils/Makefile
@@ -13,29 +13,27 @@ BINUTILS_SITE:=http://www.fr.kernel.org/pub/linux/devel/binutils \
http://ftp.kernel.org/pub/linux/devel/binutils \
http://www.de.kernel.org/pub/linux/devel/binutils
-ifeq ($(BINUTILS_VERSION),2.15)
-BINUTILS_SITE:=http://ftp.gnu.org/gnu/binutils/ \
+BINUTILS_STABLE_SITE:=http://ftp.gnu.org/gnu/binutils/ \
ftp://gatekeeper.dec.com/pub/GNU/ \
ftp://ftp.uu.net/archive/systems/gnu/ \
ftp://ftp.eu.uu.net/pub/gnu/ \
ftp://ftp.funet.fi/pub/gnu/prep/ \
ftp://ftp.leo.org/pub/comp/os/unix/gnu/
+
+ifeq ($(BINUTILS_VERSION),2.16.1)
+BINUTILS_SITE:=$(BINUTILS_STABLE_SITE)
+endif
+ifeq ($(BINUTILS_VERSION),2.16)
+BINUTILS_SITE:=$(BINUTILS_STABLE_SITE)
+endif
+ifeq ($(BINUTILS_VERSION),2.15)
+BINUTILS_SITE:=$(BINUTILS_STABLE_SITE)
endif
ifeq ($(BINUTILS_VERSION),2.14)
-BINUTILS_SITE:=http://ftp.gnu.org/gnu/binutils/ \
- ftp://gatekeeper.dec.com/pub/GNU/ \
- ftp://ftp.uu.net/archive/systems/gnu/ \
- ftp://ftp.eu.uu.net/pub/gnu/ \
- ftp://ftp.funet.fi/pub/gnu/prep/ \
- ftp://ftp.leo.org/pub/comp/os/unix/gnu/
+BINUTILS_SITE:=$(BINUTILS_STABLE_SITE)
endif
ifeq ($(BINUTILS_VERSION),2.13)
-BINUTILS_SITE:=http://ftp.gnu.org/gnu/binutils/ \
- ftp://gatekeeper.dec.com/pub/GNU/ \
- ftp://ftp.uu.net/archive/systems/gnu/ \
- ftp://ftp.eu.uu.net/pub/gnu/ \
- ftp://ftp.funet.fi/pub/gnu/prep/ \
- ftp://ftp.leo.org/pub/comp/os/unix/gnu/
+BINUTILS_SITE:=$(BINUTILS_STABLE_SITE)
endif
BINUTILS_SOURCE:=binutils-$(BINUTILS_VERSION).tar.bz2