summaryrefslogtreecommitdiff
path: root/openwrt/toolchain/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-10-07 11:57:20 +0000
commit725611a466f2edf12f809d22339b22223af4afe7 (patch)
tree4b825dc642cb6eb9a060e54bf8d69288fbee4904 /openwrt/toolchain/Makefile
parentf4dd5a6d7c4ebea48cd6292744cb9def6037de80 (diff)
move old kamikaze out of trunk - will put buildroot-ng in there as soon as all the developers are ready
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@4944 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/toolchain/Makefile')
-rw-r--r--openwrt/toolchain/Makefile57
1 files changed, 0 insertions, 57 deletions
diff --git a/openwrt/toolchain/Makefile b/openwrt/toolchain/Makefile
deleted file mode 100644
index c99116db6c..0000000000
--- a/openwrt/toolchain/Makefile
+++ /dev/null
@@ -1,57 +0,0 @@
-# Main makefile for the toolchain
-include $(TOPDIR)/rules.mk
-TARGETS:=sed utils binutils gcc uClibc ipkg-utils gdb libnotimpl
-
-TARGETS_INSTALL:=$(patsubst %,%-install,$(TARGETS))
-TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS))
-
-all: install
-install: $(TARGETS_INSTALL)
-clean: $(TARGETS_CLEAN)
-
-uClibc-prepare: kernel-headers-prepare sed-install utils-install
-binutils-prepare: uClibc-prepare
-gcc-prepare: binutils-install
-uClibc-compile: gcc-prepare
-gcc-compile: uClibc-install
-
-TOOLCHAIN_STAMP_DIR:=$(STAGING_DIR)/stampfiles
-
-$(TOOLCHAIN_STAMP_DIR):
- mkdir -p $(TOOLCHAIN_STAMP_DIR)
-
-$(STAGING_DIR):
- @mkdir -p $(STAGING_DIR)/lib
- @mkdir -p $(STAGING_DIR)/include
- @mkdir -p $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)
- @ln -sf ../lib $(STAGING_DIR)/$(REAL_GNU_TARGET_NAME)/lib
-
-$(TOOL_BUILD_DIR):
- @mkdir -p $(TOOL_BUILD_DIR)
-
-%-prepare: $(TOOLCHAIN_STAMP_DIR) $(STAGING_DIR) $(TOOL_BUILD_DIR)
- @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || { \
- $(TRACE) toolchain/$(patsubst %-prepare,%,$@)/prepare; \
- $(MAKE) -C $(patsubst %-prepare,%,$@) prepare $(MAKE_TRACE); \
- }
- @touch $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@
-
-%-compile: %-prepare
- @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || { \
- $(TRACE) toolchain/$(patsubst %-compile,%,$@)/compile; \
- $(MAKE) -C $(patsubst %-compile,%,$@) compile $(MAKE_TRACE); \
- }
- @touch $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@
-
-%-install: %-compile
- @[ -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@ ] || { \
- $(TRACE) toolchain/$(patsubst %-install,%,$@)/install; \
- $(MAKE) -C $(patsubst %-install,%,$@) install $(MAKE_TRACE); \
- }
- @touch $(TOOLCHAIN_STAMP_DIR)/.toolchain_$@
-
-%-clean:
- $(TRACE) toolchain/$(patsubst %-clean,%,$@)/clean
- @$(MAKE) -C $(patsubst %-clean,%,$@) clean $(MAKE_TRACE)
- @rm -f $(TOOLCHAIN_STAMP_DIR)/.toolchain_$(patsubst %-clean,%,$@)-*
-