summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/linux-2.4/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-10 00:20:22 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-07-10 00:20:22 +0000
commit1667aade63c66728b7d3b8389abd6e914f37dd4d (patch)
treedec676b468fb298477f9012200db052c824236ac /openwrt/target/linux/linux-2.4/Makefile
parent7822ed1a3495d28ab0f240098a0c057c5f6cdf4d (diff)
add ar7 adsl driver support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1387 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/linux-2.4/Makefile')
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index de0f815cad..31a3775767 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -53,6 +53,16 @@ include ./broadcom.mk
endif
+$(eval $(call KMOD_template,SANGAM_ATM,sangam-atm,\
+ $(MODULES_DIR)/kernel/drivers/atm/tiatm.o \
+,CONFIG_MIPS_SANGAM_ATM))
+$(eval $(call KMOD_template,ATM,atm,\
+ $(MODULES_DIR)/kernel/net/atm/atm.o \
+ $(MODULES_DIR)/kernel/net/atm/br2684.o \
+,CONFIG_ATM))
+$(eval $(call KMOD_template,PPPOATM,pppoatm,\
+ $(MODULES_DIR)/kernel/net/atm/pppoatm.o \
+,CONFIG_PPPOATM))
$(eval $(call KMOD_template,CPMAC,cpmac,\
$(MODULES_DIR)/kernel/drivers/net/avalanche_cpmac/avalanche_cpmac.o \
,CONFIG_MIPS_AVALANCHE_CPMAC))