summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-12 13:59:13 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-08-12 13:59:13 +0000
commitec6b42c03362880320fdf6b9bb53ae9877813ed7 (patch)
tree72e58776dc3943395f52c3058cc9ee96565a7eb0 /openwrt/target/linux/image
parent9de8a3dd724d4361e7045e05585ae435705d8f8e (diff)
add pspboot support, cleanup in ar7 board support
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1611 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/image')
-rw-r--r--openwrt/target/linux/image/ar7/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/openwrt/target/linux/image/ar7/Makefile b/openwrt/target/linux/image/ar7/Makefile
index ee2b570eb7..1d1aea725b 100644
--- a/openwrt/target/linux/image/ar7/Makefile
+++ b/openwrt/target/linux/image/ar7/Makefile
@@ -64,14 +64,15 @@ $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin: $(BIN_DIR)/openwrt-ar7-2.4-kernel.bi
define pattern_template
$(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS)-$(1).bin: $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin
(dd if=/dev/zero bs=16 count=1; cat $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS).bin) | \
- $(STAGING_DIR)/bin/addpattern -p $(1) -o $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS)-$(1).bin
-
+ $(STAGING_DIR)/bin/addpattern -p $(1) $(2) -o $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS)-$(1).bin
+
install: $(BIN_DIR)/openwrt-ar7-$(KERNEL)-$(FS)-$(1).bin
endef
$(eval $(call pattern_template,WA22))
$(eval $(call pattern_template,WAG2))
$(eval $(call pattern_template,WA21))
+$(eval $(call pattern_template,WA32,-b))
clean:
rm -rf $(PKG_BUILD_DIR)