summaryrefslogtreecommitdiff
path: root/openwrt/target/linux/image/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-11 21:18:26 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-11 21:18:26 +0000
commita80d25042b8914774c614f8b2ff26e02bcbe0461 (patch)
tree8813ca5ad209754da7f4b71014c7a131ee200196 /openwrt/target/linux/image/Makefile
parent4fba88b87b0e46c76bdc0757e60010affa09f9d0 (diff)
cleanup in target/
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@1205 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/target/linux/image/Makefile')
-rw-r--r--openwrt/target/linux/image/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/openwrt/target/linux/image/Makefile b/openwrt/target/linux/image/Makefile
new file mode 100644
index 0000000000..6b7c78774c
--- /dev/null
+++ b/openwrt/target/linux/image/Makefile
@@ -0,0 +1,24 @@
+include $(TOPDIR)/rules.mk
+
+ifeq ($(BOARD),)
+BOARD:=brcm
+endif
+
+KDIR:=$(BUILD_DIR)/linux-$(KERNEL)-$(BOARD)
+
+ifeq ($(BR2_TARGET_ROOTFS_JFFS2),y)
+include ./jffs2.mk
+endif
+
+ifeq ($(BR2_TARGET_ROOTFS_SQUASHFS_LZMA),y)
+include ./squashfs.mk
+endif
+
+prepare:
+ $(MAKE) -C $(BOARD) prepare
+compile:
+ $(MAKE) -C $(BOARD) compile
+install:
+rebuild: clean prepare compile install
+clean:
+