summaryrefslogtreecommitdiff
path: root/openwrt/package/tcp_wrappers
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-08 09:08:38 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-08 09:08:38 +0000
commite8d897309949d4c2cc7a77ba0e6ca84f071fa6e9 (patch)
tree66a9a28ea0c69b059939becc0f335bc8ec1d5437 /openwrt/package/tcp_wrappers
parent75821f0878d074fff9467e4c74d2ed718a35002f (diff)
add some fixes for parallel build (does not work with -j4 yet, but it gets most packages compiled now)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@577 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/tcp_wrappers')
-rw-r--r--openwrt/package/tcp_wrappers/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/tcp_wrappers/Makefile b/openwrt/package/tcp_wrappers/Makefile
index 84f98160d5..40e7331af1 100644
--- a/openwrt/package/tcp_wrappers/Makefile
+++ b/openwrt/package/tcp_wrappers/Makefile
@@ -16,6 +16,7 @@ PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_SOURCE_DIR)
# only need libwrap.a at the moment
#PKG_IPK := $(PACKAGE_DIR)/zlib_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+.NOTPARALLEL:
$(DL_DIR)/$(PKG_SOURCE_FILE):
mkdir -p $(DL_DIR)
@@ -28,8 +29,7 @@ $(PKG_BUILD_DIR)/.patched: $(DL_DIR)/$(PKG_SOURCE_FILE)
touch $(PKG_BUILD_DIR)/.patched
$(PKG_BUILD_DIR)/libwrap.a: $(PKG_BUILD_DIR)/.patched
-
- $(MAKE) -C $(PKG_BUILD_DIR) \
+ $(MAKE) -j1 -C $(PKG_BUILD_DIR) \
$(TARGET_CONFIGURE_OPTS) \
COPTS="$(TARGET_CFLAGS)" \
LIBS=-lnsl \