summaryrefslogtreecommitdiff
path: root/openwrt/package/ppp
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-21 08:12:49 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-21 08:12:49 +0000
commitec8fa5540e88f076526bfaa388c8a4d406e37bff (patch)
tree9746d68e62ad8ee899d82224609b6e7924364e40 /openwrt/package/ppp
parent0d8d0c34edda6c930a1dcda0f057ac514ef90f80 (diff)
add md5sums
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@405 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/ppp')
-rw-r--r--openwrt/package/ppp/Makefile6
1 files changed, 4 insertions, 2 deletions
diff --git a/openwrt/package/ppp/Makefile b/openwrt/package/ppp/Makefile
index 032a228e00..92dceecd05 100644
--- a/openwrt/package/ppp/Makefile
+++ b/openwrt/package/ppp/Makefile
@@ -1,14 +1,16 @@
+# $Id$
+
include $(TOPDIR)/rules.mk
PKG_NAME := ppp
PKG_VERSION := 2.4.3
PKG_RELEASE := 3
+PKG_MD5SUM := 848f6c3cafeb6074ffeb293c3af79b7c
PKG_SOURCE_SITE := ftp://ftp.samba.org/pub/ppp/
PKG_SOURCE_FILE := $(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_CAT := zcat
PKG_SOURCE_DIR := $(PKG_NAME)-$(PKG_VERSION)
-
PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_SOURCE_DIR)
PKG_PPP := $(PACKAGE_DIR)/ppp_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
@@ -53,7 +55,7 @@ endif
$(DL_DIR)/$(PKG_SOURCE_FILE):
mkdir -p $(DL_DIR)
- $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE_FILE) x $(PKG_SOURCE_SITE)
+ $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE_FILE) $(PKG_MD5SUM) $(PKG_SOURCE_SITE)
$(PKG_BUILD_DIR)/.patched: $(DL_DIR)/$(PKG_SOURCE_FILE)
mkdir -p $(TOOL_BUILD_DIR)