summaryrefslogtreecommitdiff
path: root/openwrt/package/ncurses/Makefile
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-18 06:34:57 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-18 06:34:57 +0000
commit72d1969f67c376a8513904705f9ac0febe07f991 (patch)
treee6ebdb7b1ef3288be5c8d868847974350beaf317 /openwrt/package/ncurses/Makefile
parent818f981f7736524e5da3bc287471245e8bab8d68 (diff)
Uniformize package Makefile, move ipkg related files to ./ipkg
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@665 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/ncurses/Makefile')
-rw-r--r--openwrt/package/ncurses/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/openwrt/package/ncurses/Makefile b/openwrt/package/ncurses/Makefile
index b15152634c..3591fa0c7b 100644
--- a/openwrt/package/ncurses/Makefile
+++ b/openwrt/package/ncurses/Makefile
@@ -94,9 +94,9 @@ $(STAGING_DIR)/usr/lib/libncurses.so: $(PKG_BUILD_DIR)/.built
install
$(IPKG_LIBNCURSES): $(STAGING_DIR)/usr/lib/libncurses.so
- $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_LIBNCURSES) lib$(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_LIBNCURSES) ./ipkg/lib$(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
mkdir -p $(IDIR_LIBNCURSES)/usr/lib
- cp -fp $(STAGING_DIR)/usr/lib/lib{ncurses,panel}*.so.* $(IDIR_LIBNCURSES)/usr/lib/
+ cp -fpR $(STAGING_DIR)/usr/lib/lib{ncurses,panel}*.so.* $(IDIR_LIBNCURSES)/usr/lib/
$(STRIP) $(IDIR_LIBNCURSES)/usr/lib/*.so*
mkdir -p $(IDIR_LIBNCURSES)/usr/share/terminfo
for f in a/ansi d/dumb l/linux s/screen v/vt100 x/xterm x/xterm-color; do \