summaryrefslogtreecommitdiff
path: root/openwrt/package/iptables/iptables.mk
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-02-19 07:40:42 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-02-19 07:40:42 +0000
commit9de7746a19132595b6b39561fba6a9ee5c2ad1a4 (patch)
treef00e1fc8cd0ce67531c7a76dad97797766b276e6 /openwrt/package/iptables/iptables.mk
parent094dace1afbc42a83bbc2e9e4099c5f391b2b0a0 (diff)
sync with buildroot2 from uclibc
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@262 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/iptables/iptables.mk')
-rw-r--r--openwrt/package/iptables/iptables.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/openwrt/package/iptables/iptables.mk b/openwrt/package/iptables/iptables.mk
index 99cf14f275..e343a6122e 100644
--- a/openwrt/package/iptables/iptables.mk
+++ b/openwrt/package/iptables/iptables.mk
@@ -39,7 +39,7 @@ $(TARGET_DIR)/usr/sbin/iptables: $(IPTABLES_BUILD_DIR)/iptables
$(STRIP) $(TARGET_DIR)/usr/lib/iptables/*.so
rm -rf $(TARGET_DIR)/usr/man
-iptables: $(TARGET_DIR)/usr/sbin/iptables
+iptables: kernel-headers $(TARGET_DIR)/usr/sbin/iptables
iptables-source: $(DL_DIR)/$(IPTABLES_SOURCE)
@@ -49,3 +49,7 @@ iptables-clean:
iptables-dirclean:
rm -rf $(IPTABLES_BUILD_DIR)
+
+ifeq ($(strip $(BR2_PACKAGE_IPTABLES)),y)
+TARGETS+=iptables
+endif