summaryrefslogtreecommitdiff
path: root/openwrt/package/chillispot
diff options
context:
space:
mode:
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-11 00:57:23 +0000
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-11 00:57:23 +0000
commit8741e7b81dce36ebfbc3a5643e11f2d3a9fda4eb (patch)
tree367c08a07bbc58a2ec7ac96ea65d2692d3ae64a4 /openwrt/package/chillispot
parent7ec4baf39b6c7dd270f1eb51f886a279e146d2c7 (diff)
Fix chillispot configure and install
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@622 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/package/chillispot')
-rw-r--r--openwrt/package/chillispot/Makefile11
1 files changed, 7 insertions, 4 deletions
diff --git a/openwrt/package/chillispot/Makefile b/openwrt/package/chillispot/Makefile
index 71736aedc3..454105d082 100644
--- a/openwrt/package/chillispot/Makefile
+++ b/openwrt/package/chillispot/Makefile
@@ -32,6 +32,8 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
--target=$(GNU_TARGET_NAME) \
--host=$(GNU_TARGET_NAME) \
--build=$(GNU_HOST_NAME) \
+ --program-prefix="" \
+ --program-suffix="" \
--prefix=/usr \
--exec-prefix=/usr \
--bindir=/usr/bin \
@@ -39,11 +41,12 @@ $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
--includedir=/usr/include \
--infodir=/usr/share/info \
--libdir=/usr/lib \
- --libexecdir=/usr/lib/locate \
- --localstatedir=/var/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
--mandir=/usr/share/man \
--sbindir=/usr/sbin \
--sysconfdir=/etc \
+ $(DISABLE_LARGEFILE) \
$(DISABLE_NLS) \
);
touch $(PKG_BUILD_DIR)/.configured
@@ -63,13 +66,13 @@ $(PKG_IPK): $(PKG_BUILD_DIR)/src/chilli
mkdir -p $(PACKAGE_DIR)
$(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
-$(IPKG_STATE_DIR)/info/openvpn.list: $(PKG_IPK)
+$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
$(IPKG) install $(PKG_IPK)
source: $(DL_DIR)/$(PKG_SOURCE)
prepare: $(PKG_BUILD_DIR)/.unpacked
compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/openvpn.list
+install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
clean:
rm -rf $(PKG_BUILD_DIR)