summaryrefslogtreecommitdiff
path: root/openwrt/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-20 17:01:30 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-04-20 17:01:30 +0000
commitd4acdafcf724057bc9b718170c54b420f46c40b4 (patch)
treed54625559910142e0895d8a2318d003de21a286c /openwrt/Makefile
parentb91216ac5fe33ba6166ab40915fdb8040f470b4e (diff)
add openwrt image builder to sdk
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@688 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/Makefile')
-rw-r--r--openwrt/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index e966188187..cd94233149 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -61,8 +61,11 @@ toolchain_install:
#
##############################################################
-package_install: toolchain
- $(MAKE) -C package compile install
+package_compile: target_compile
+ $(MAKE) -C package compile
+
+package_install: package_compile toolchain
+ $(MAKE) -C package install
#############################################################
#
@@ -91,6 +94,9 @@ package_index:
target_prepare:
$(MAKE) -C target prepare
+target_compile:
+ $(MAKE) -C target compile
+
target_install:
$(MAKE) -C target install