summaryrefslogtreecommitdiff
path: root/openwrt/Makefile
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-07 15:11:58 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-03-07 15:11:58 +0000
commit5115abb64a067aead31b82baa3bd35a48445c7f3 (patch)
tree063113af2e3b1b9f2c4f7ea87a5e575be5855492 /openwrt/Makefile
parent3d2dbd0b3dfeef11cb502c524c130e2038498782 (diff)
create a package index after build
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@337 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/Makefile')
-rw-r--r--openwrt/Makefile11
1 files changed, 4 insertions, 7 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index ed4ea1529f..1a218df586 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -69,16 +69,13 @@ package_install: toolchain
# In this section, we need .config
include .config.cmd
-world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install package_install target_install
+world: $(DL_DIR) $(BUILD_DIR) target_prepare $(TARGET_DIR) toolchain_install package_install target_install package_index
.PHONY: all world clean dirclean distclean image_clean target_clean source target_prepare target_install toolchain_install package_install
-#############################################################
-#
-# staging and target directories do NOT list these as
-# dependancies anywhere else
-#
-#############################################################
+package_index:
+ $(STAGING_DIR)/usr/bin/ipkg-make-index $(PACKAGE_DIR) > $(PACKAGE_DIR)/Packages
+
target_prepare:
$(MAKE) -C target prepare