summaryrefslogtreecommitdiff
path: root/openwrt/Makefile
diff options
context:
space:
mode:
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-14 22:13:32 +0000
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-04-14 22:13:32 +0000
commit40152cc646ac4cd24d5f1473fdac7974b0f419aa (patch)
tree7e69218ec25b19c70cff6ca4b84d964ac547e918 /openwrt/Makefile
parent3855bdc4e0c3acf2496f36e3d4b696dd0b4deefc (diff)
cleanup makefiles
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@3656 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'openwrt/Makefile')
-rw-r--r--openwrt/Makefile9
1 files changed, 2 insertions, 7 deletions
diff --git a/openwrt/Makefile b/openwrt/Makefile
index abc9dfee27..2fdc7647d4 100644
--- a/openwrt/Makefile
+++ b/openwrt/Makefile
@@ -34,7 +34,7 @@ CONFIG_DEFCONFIG = .defconfig
CONFIG = package/config
noconfig_targets := menuconfig config oldconfig randconfig \
- defconfig allyesconfig allnoconfig release tags
+ defconfig allyesconfig allnoconfig tags
# Pull in the user's configuration file
ifeq ($(filter $(noconfig_targets),$(MAKECMDGOALS)),)
@@ -47,6 +47,7 @@ include $(TOPDIR)/rules.mk
all: world
.NOTPARALLEL:
+.PHONY: all world clean dirclean distclean image_clean target_clean source configtest
#############################################################
#
@@ -62,8 +63,6 @@ world: $(DL_DIR) $(BUILD_DIR) configtest
$(MAKE) toolchain/install target/compile package/compile root_clean package/install target/install package_index
@$(TRACE) Build complete.
-.PHONY: all world clean dirclean distclean image_clean target_clean source configtest
-
configtest:
-cp .config .config.test
-scripts/configtest.pl
@@ -177,7 +176,3 @@ defconfig: $(CONFIG)/conf
-./scripts/configtest.pl
endif # ifeq ($(strip $(BR2_HAVE_DOT_CONFIG)),y)
-
-.PHONY: dummy subdirs release distclean clean config oldconfig \
- menuconfig tags check test depend
-