summaryrefslogtreecommitdiff
path: root/obsolete-buildroot
diff options
context:
space:
mode:
authorgroz <groz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2004-06-08 08:39:07 +0000
committergroz <groz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2004-06-08 08:39:07 +0000
commit16580b1e00d2b3bd6b52d6dfcfe54bcb1db6bb9d (patch)
tree738d5b0612d038b1dbe826d11734abfb2de0b21f /obsolete-buildroot
parent2901ca675b2efbd0caaed3ec305fb913fe80dfdf (diff)
Added the ipackage repository target, and the logic to expand the PACKAGES
target into all the various ipk files, and generate a repository from the listed targets. git-svn-id: svn://svn.openwrt.org/openwrt/trunk@68 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'obsolete-buildroot')
-rw-r--r--obsolete-buildroot/Makefile24
1 files changed, 23 insertions, 1 deletions
diff --git a/obsolete-buildroot/Makefile b/obsolete-buildroot/Makefile
index cf68d065c2..e2219c66db 100644
--- a/obsolete-buildroot/Makefile
+++ b/obsolete-buildroot/Makefile
@@ -40,6 +40,8 @@ BUILD_WITH_LARGEFILE:=true
OPTIMIZE_FOR_CPU=$(ARCH)
+PUB_DIR:=/var/www/html/testsite/ipkg
+
# Command used to download source code
WGET:=wget --passive-ftp
@@ -97,6 +99,8 @@ INSTALL_LIBGCJ:=false
#############################################################
TARGETS:=host-sed gcc3_3 openwrt-base openwrt-code.bin
+PACKAGES:=oidentd iproute2 sched-modules wshaper
+
#############################################################
#
# You should probably leave this stuff alone unless you know
@@ -183,7 +187,14 @@ TARGETS_CLEAN:=$(patsubst %,%-clean,$(TARGETS))
TARGETS_SOURCE:=$(patsubst %,%-source,$(TARGETS))
TARGETS_DIRCLEAN:=$(patsubst %,%-dirclean,$(TARGETS))
-world: $(DL_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) $(TARGETS)
+
+PACKAGES_IPK:=$(patsubst %,%-ipk,$(PACKAGES))
+
+
+$(BUILD_DIR)/Packages : $(PACKAGES_IPK)
+ (cd $(BUILD_DIR) ; ipkg-make-index . > Packages)
+
+world: $(DL_DIR) $(BUILD_DIR) $(STAGING_DIR) $(TARGET_DIR) $(TARGETS) $(PACKAGES_IPK) $(BUILD_DIR)/Packages
@echo "ALL DONE."
.PHONY: all world clean dirclean distclean source $(TARGETS) \
@@ -240,6 +251,17 @@ distclean:
rm -rf $(DL_DIR) $(BUILD_DIR) $(LINUX_KERNEL) $(IMAGE) \
openwrt-linux.trx openwrt-g-code.bin openwrt-gs-code.bin \
openwrt-kmodules.tar.bz2
+
+
+publish:
+ chmod 644 $(BUILD_DIR)/Packages
+ chmod 644 $(BUILD_DIR)/Packages.filelist
+ chmod 644 $(BUILD_DIR)/*.ipk
+ cp $(BUILD_DIR)/Packages $(PUB_DIR)
+ cp $(BUILD_DIR)/Packages.filelist $(PUB_DIR)
+ cp $(BUILD_DIR)/*.ipk $(PUB_DIR)
+
+
sourceball:
rm -rf $(BUILD_DIR)