summaryrefslogtreecommitdiff
path: root/obsolete-buildroot/sources/hotplug.patch
diff options
context:
space:
mode:
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2004-05-25 04:32:27 +0000
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>2004-05-25 04:32:27 +0000
commit3ac1acb9ea70080aaaf49ae211835f057e60eefa (patch)
treea2e08d2be3224409a033d25af8861d9853e72de7 /obsolete-buildroot/sources/hotplug.patch
parent1eb1b593980fdc06ab92f8e354129b0aadc4f1b0 (diff)
Initial revision
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'obsolete-buildroot/sources/hotplug.patch')
-rw-r--r--obsolete-buildroot/sources/hotplug.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/obsolete-buildroot/sources/hotplug.patch b/obsolete-buildroot/sources/hotplug.patch
new file mode 100644
index 0000000000..22c356b227
--- /dev/null
+++ b/obsolete-buildroot/sources/hotplug.patch
@@ -0,0 +1,33 @@
+diff -urN diethotplug-0.4.orig/pci.c diethotplug-0.4/pci.c
+--- diethotplug-0.4.orig/pci.c Wed Jan 9 13:57:29 2002
++++ diethotplug-0.4/pci.c Wed Jan 30 22:35:24 2002
+@@ -68,8 +68,8 @@
+ }
+
+ /* check that the class matches */
+- class_temp = pci_module_map[i].class_mask & pci_class;
+- if (pci_module_map[i].class != class_temp) {
++ class_temp = (pci_module_map[i].class ^ pci_class) & pci_module_map[i].class_mask;
++ if (class_temp != 0) {
+ dbg ("class mask check failed %x != %x",
+ pci_module_map[i].class, class_temp);
+ continue;
+--- diethotplug-0.4/Makefile.orig Wed Jan 9 14:28:05 2002
++++ diethotplug-0.4/Makefile Mon Jul 8 07:29:00 2002
+@@ -135,13 +135,13 @@
+
+ # Rules on how to create the generated header files
+ usb_modules.h:
+- perl convert_usb.pl < /lib/modules/$(KERNEL_VERSION)/modules.usbmap > $@
++ perl convert_usb.pl < $(TARGET_DIR)/lib/modules/$(KERNEL_VERSION)/modules.usbmap > $@
+
+ pci_modules.h:
+- perl convert_pci.pl < /lib/modules/$(KERNEL_VERSION)/modules.pcimap > $@
++ perl convert_pci.pl < $(TARGET_DIR)/lib/modules/$(KERNEL_VERSION)/modules.pcimap > $@
+
+ ieee1394_modules.h:
+- perl convert_ieee1394.pl < /lib/modules/$(KERNEL_VERSION)/modules.ieee1394map > $@
++ perl convert_ieee1394.pl < $(TARGET_DIR)/lib/modules/$(KERNEL_VERSION)/modules.ieee1394map > $@
+
+ hotplug_version.h:
+ @echo \#define HOTPLUG_VERSION \"$(VERSION)\" > $@