summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-03-13 12:12:58 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2014-03-13 12:12:58 +0000
commitb07e567e6cc425b2293fbc83c187c1558fdf186b (patch)
tree07d6fc0552fea718c9c1017c66159914cba63e6b /include
parent4b07676d91294bca0ebafb9424320238c005f302 (diff)
target/sdk: use .config instead of unconditionally enabling all build dirs
Call make defconfig on every build to catch newly added packages Signed-off-by: Felix Fietkau <nbd@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@39913 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/toplevel.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/include/toplevel.mk b/include/toplevel.mk
index 23d70ac81a..10b81049c5 100644
--- a/include/toplevel.mk
+++ b/include/toplevel.mk
@@ -156,6 +156,15 @@ prereq:: prepare-tmpinfo .config
@+$(MAKE) -r -s tmp/.prereq-build $(PREP_MK)
@+$(NO_TRACE_MAKE) -r -s $@
+ifeq ($(SDK),1)
+
+%::
+ @+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq
+ @./scripts/config/conf --defconfig=.config Config.in
+ @+$(ULIMIT_FIX) $(SUBMAKE) -r $@
+
+else
+
%::
@+$(PREP_MK) $(NO_TRACE_MAKE) -r -s prereq
@( \
@@ -167,6 +176,8 @@ prereq:: prepare-tmpinfo .config
)
@+$(ULIMIT_FIX) $(SUBMAKE) -r $@
+endif
+
help:
cat README