summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-02-02 08:23:44 +0000
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>2012-02-02 08:23:44 +0000
commit8ae6c0c8351cb93b8b059567ab3f33a340641185 (patch)
treee839b65938b53d11db735977952021fb5184b934 /include
parent2efef569b8e620e955870865dd7848669362ec01 (diff)
kernel: update module names and add new config symbols for linux 3.3
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29985 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/netfilter.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/include/netfilter.mk b/include/netfilter.mk
index 29dbbc4e57..1cbb9a8b86 100644
--- a/include/netfilter.mk
+++ b/include/netfilter.mk
@@ -116,7 +116,6 @@ $(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_TARGET_DSCP, $(P_V4)ipt_DSCP))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_MATCH_DSCP, $(P_XT)xt_dscp))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_TARGET_DSCP, $(P_XT)xt_DSCP))
$(eval $(call nf_add,IPT_HASHLIMIT,CONFIG_NETFILTER_XT_MATCH_HASHLIMIT, $(P_XT)xt_hashlimit))
-$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_ECN, $(P_V4)ipt_ecn))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_LENGTH, $(P_V4)ipt_length))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_MATCH_LENGTH, $(P_XT)xt_length))
$(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_MARK, $(P_V4)ipt_mark))
@@ -144,6 +143,12 @@ else
$(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_TARGET_MARK, $(P_XT)xt_MARK))
endif
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
+ $(eval $(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_MATCH_ECN, $(P_XT)xt_ecn))
+else
+ $(eval $(call nf_add,IPT_IPOPT,CONFIG_IP_NF_MATCH_ECN, $(P_V4)ipt_ecn))
+endif
+
# userland only
$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_MATCH_DSCP, $(P_XT)xt_tos)))
$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_IPOPT,CONFIG_NETFILTER_XT_TARGET_DSCP, $(P_XT)xt_TOS)))
igskaloz 2009-10-23[kernel] update to 2.6.30.9florian 2009-10-05[kernel] move common CONFIG_FB entries to genericnico 2009-10-01kernel: upgrade to 2.6.30.8 and refresh patchesjuhosg 2009-09-17update to latest 2.6.27 and 2.6.30 kernelskaloz 2009-09-09[kernel] update to 2.6.30.6, compile tested on some targets onlyflorian 2009-08-27pxcab: Add config-2.6.31geoff 2009-08-27pxcab: Build fixgeoff 2009-08-18pxcab: Replace TARGET_pxcab with feature powerpc64geoff 2009-08-17[kernel] use 2.6.30.5florian 2009-07-31[kernel] update to 2.6.30.4florian 2009-07-27[kernel] switch to 2.6.30.3florian 2009-07-25[pxcab] resync kernel configurationflorian 2009-07-20update to 2.6.30.2kaloz 2009-07-16This patch adds a target for the IBM PowerXCell Accelerator Board.florian