summaryrefslogtreecommitdiff
path: root/include
diff options
context:
space:
mode:
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-11-22 12:01:01 +0000
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-11-22 12:01:01 +0000
commit79729165822dd51fdaf99178d809ca3fa37c92e5 (patch)
tree7f3b0c4f159dcf61069c425d3d16f37230a4b1f0 /include
parentb55a58764ba3df56ad4b496a42b3b00682bd8546 (diff)
add a feature flag for device tree support
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38893 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'include')
-rw-r--r--include/target.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/include/target.mk b/include/target.mk
index 467ef35766..acb9adf584 100644
--- a/include/target.mk
+++ b/include/target.mk
@@ -167,6 +167,9 @@ ifeq ($(DUMP),1)
.SILENT: $(TMP_CONFIG)
.PRECIOUS: $(TMP_CONFIG)
+ ifneq ($(CONFIG_OF),)
+ FEATURES += dt
+ endif
ifneq ($(CONFIG_GENERIC_GPIO)$(CONFIG_GPIOLIB),)
FEATURES += gpio
endif