summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-07-01 15:36:12 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-07-01 15:36:12 +0000
commitdb0b0e5fb956bacf64b52163c44d041954becbbd (patch)
tree4b6593d58e23dda1041865e31ee0d9294adc7f60
parentd00d864dc467e9c0c62e978a290a524eb43c7766 (diff)
libjson-c: rename the libjson binary package to libjson-c, add a new libjson package with the compatibility library (to deal with the rename)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37119 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/libs/libjson-c/Makefile27
-rw-r--r--package/libs/libubox/Makefile4
2 files changed, 26 insertions, 5 deletions
diff --git a/package/libs/libjson-c/Makefile b/package/libs/libjson-c/Makefile
index cc82df48fe..3a8a41b515 100644
--- a/package/libs/libjson-c/Makefile
+++ b/package/libs/libjson-c/Makefile
@@ -27,30 +27,51 @@ include $(INCLUDE_DIR)/package.mk
TARGET_CFLAGS += $(FPIC)
-define Package/libjson
+define Package/libjson-c
SECTION:=libs
CATEGORY:=Libraries
TITLE:=javascript object notation
URL:=http://oss.metaparadigm.com/json-c/
endef
-define Package/libjson/description
+define Package/libjson-c/description
This package contains a library for javascript object notation backends.
endef
+define Package/libjson
+ SECTION:=libs
+ CATEGORY:=Libraries
+ DEPENDS:=+libjson-c
+ TITLE:=javascript object notation (compat library)
+ URL:=http://oss.metaparadigm.com/json-c/
+endef
+
+define Package/libjson/description
+ This package contains a compatibility library for packages that have not
+ been adapted to the json-c library rename yet
+endef
+
+
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(CP) $(PKG_INSTALL_DIR)/usr/include/json $(1)/usr/include/
$(CP) $(PKG_INSTALL_DIR)/usr/include/json-c $(1)/usr/include/
$(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson.{a,so*} $(1)/usr/lib/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson-c.{a,so*} $(1)/usr/lib/
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/json-c.pc $(1)/usr/lib/pkgconfig/
endef
-define Package/libjson/install
+define Package/libjson-c/install
$(INSTALL_DIR) $(1)/usr/lib
$(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson-c.so.* $(1)/usr/lib/
endef
+define Package/libjson/install
+ $(INSTALL_DIR) $(1)/usr/lib
+ $(CP) $(PKG_INSTALL_DIR)/usr/lib/libjson.so.* $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libjson-c))
$(eval $(call BuildPackage,libjson))
diff --git a/package/libs/libubox/Makefile b/package/libs/libubox/Makefile
index 231a5875bd..5eebc6e183 100644
--- a/package/libs/libubox/Makefile
+++ b/package/libs/libubox/Makefile
@@ -33,13 +33,13 @@ define Package/libblobmsg-json
SECTION:=libs
CATEGORY:=Libraries
TITLE:=blobmsg <-> json conversion library
- DEPENDS:=+libjson +libubox
+ DEPENDS:=+libjson-c +libubox
endef
define Package/jshn
SECTION:=utils
CATEGORY:=Utilities
- DEPENDS:=+libjson
+ DEPENDS:=+libjson-c
TITLE:=JSON SHell Notation
endef