summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-09-22 09:11:25 +0000
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-09-22 09:11:25 +0000
commitaf215890d05dc1711100f5afd604b3ffaf27382f (patch)
treeccce3e4bf2437c7a882d52bd2331f87ff586bf72
parentc979784af9fe350a7a42c5166eb89e11ac54a2f4 (diff)
ar71xx: image: add mtdpartsize macro
The new macro will be used to determine the firmware partition size from an MTD layout. Signed-off-by: Gabor Juhos <juhosg@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38117 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/ar71xx/image/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 60990b284d..8ac70448d5 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -31,6 +31,10 @@ define mkcmdline
$(if $(1),board=$(1) )$(if $(2),console=$(2)$(COMMA)$(3))
endef
+define mtdpartsize
+$(shell echo $$((`echo '$(2)' | sed -e 's/.*[:$(COMMA)]\([0-9]*\)k[@]*[0-9a-zx]*($(1)).*/\1/'` * 1024)))
+endef
+
SINGLE_PROFILES:=
define SingleProfile