summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-11-22 09:39:41 +0000
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-11-22 09:39:41 +0000
commit77d12ceb91313c0283adfe23e7dcdec1abd11c6f (patch)
treeb158d1ac046a4534d849744c82980da6bd52ddbc
parentb8bb81bfa1df55d15d185c593c2cdf89863563d1 (diff)
allow configuration of the target directory for binaries
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38890 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--Config.in4
-rw-r--r--rules.mk2
2 files changed, 5 insertions, 1 deletions
diff --git a/Config.in b/Config.in
index 4f7667aa1f..bf1e139f2e 100644
--- a/Config.in
+++ b/Config.in
@@ -421,6 +421,10 @@ menuconfig DEVEL
bool "Show broken platforms / packages" if DEVEL
default n
+ config BINARY_FOLDER
+ string "Binary folder" if DEVEL
+ default ""
+
config DOWNLOAD_FOLDER
string "Download folder" if DEVEL
default ""
diff --git a/rules.mk b/rules.mk
index a3efb7db4f..80e07d11a2 100644
--- a/rules.mk
+++ b/rules.mk
@@ -73,7 +73,7 @@ ifdef CONFIG_MIPS64_ABI
endif
DL_DIR:=$(if $(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(call qstrip,$(CONFIG_DOWNLOAD_FOLDER)),$(TOPDIR)/dl)
-BIN_DIR:=$(TOPDIR)/bin/$(BOARD)
+BIN_DIR:=$(if $(call qstrip,$(CONFIG_BINARY_FOLDER)),$(call qstrip,$(CONFIG_BINARY_FOLDER)),$(TOPDIR)/bin/$(BOARD))
INCLUDE_DIR:=$(TOPDIR)/include
SCRIPT_DIR:=$(TOPDIR)/scripts
BUILD_DIR_BASE:=$(TOPDIR)/build_dir