summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-11 01:50:07 +0000
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>2005-06-11 01:50:07 +0000
commit470cdcc4e636fb3d5c1937c212088169c5e7a068 (patch)
tree8938d94417153055974887588693e29ed5930893
parent7ba5515294f1d5c606e8d00f675c71401215a1d3 (diff)
add kernel package with version-specific /etc/modules
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@1195 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--target/linux/control/kernel.control6
-rw-r--r--target/linux/linux-2.4/Makefile16
-rw-r--r--target/linux/linux-2.4/config/brcm.modules2
-rw-r--r--target/linux/rules.mk2
4 files changed, 22 insertions, 4 deletions
diff --git a/target/linux/control/kernel.control b/target/linux/control/kernel.control
new file mode 100644
index 0000000000..5432d21a0f
--- /dev/null
+++ b/target/linux/control/kernel.control
@@ -0,0 +1,6 @@
+Package: kernel
+Priority: optional
+Section: sys
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Description: Virtual package for the Kernel
diff --git a/target/linux/linux-2.4/Makefile b/target/linux/linux-2.4/Makefile
index c9b61a6cdc..db7d71c16a 100644
--- a/target/linux/linux-2.4/Makefile
+++ b/target/linux/linux-2.4/Makefile
@@ -40,6 +40,9 @@ MODULES_DIR := $(LINUX_BUILD_DIR)/modules/$(MODULES_SUBDIR)
TARGET_MODULES_DIR := $(TARGET_DIR)/lib/modules/$(LINUX_VERSION)
IPKG_KERNEL:=IPKG_TMP=$(BUILD_DIR)/tmp IPKG_INSTROOT=$(LINUX_TARGET_DIR) IPKG_CONF_DIR=$(LINUX_BUILD_DIR) $(SCRIPT_DIR)/ipkg -force-defaults -force-depends
+KERNEL_IPKG:=$(LINUX_BUILD_DIR)/kernel_$(LINUX_VERSION)-$(BOARD)_$(ARCH).ipk
+KERNEL_IDIR:=$(LINUX_BUILD_DIR)/kernel-ipkg
+
include $(LINUX_KCONFIG)
ifeq ($(BOARD),brcm)
include ./broadcom.mk
@@ -49,7 +52,7 @@ PKG_BUILD_DIR := $(LINUX_BUILD_DIR)/linux-modules
PKG_RELEASE := 1
TARGETS :=
-INSTALL_TARGETS :=
+INSTALL_TARGETS := $(KERNEL_IPKG)
$(eval $(call KMOD_template,DIAG,diag,\
$(MODULES_DIR)/kernel/drivers/net/diag/diag.o \
@@ -210,6 +213,15 @@ $(STAGING_DIR)/include/linux/version.h: $(LINUX_DIR)/.configured
$(TARGET_MODULES_DIR):
-mkdir -p $(TARGET_MODULES_DIR)
+$(KERNEL_IPKG):
+ rm -rf $(KERNEL_IDIR)
+ mkdir -p $(KERNEL_IDIR)/etc
+ $(SCRIPT_DIR)/make-ipkg-dir.sh $(KERNEL_IDIR) ../control/kernel.control $(LINUX_VERSION)-$(BOARD) $(ARCH)
+ if [ -f ./config/$(BOARD).modules ]; then \
+ cp ./config/$(BOARD).modules $(KERNEL_IDIR)/etc/modules; \
+ fi
+ $(IPKG_BUILD) $(KERNEL_IDIR) $(LINUX_BUILD_DIR)
+
source: $(DL_DIR)/$(LINUX_SOURCE)
prepare: $(LINUX_DIR)/.configured
compile: $(LINUX_DIR)/.modules_done $(TARGETS)
@@ -220,7 +232,7 @@ compile: $(LINUX_DIR)/.modules_done $(TARGETS)
KERNEL_DIR="$(LINUX_SOURCE_DIR)" \
LINUX_VERSION="$(LINUX_VERSION)"
-install: compile $(TARGET_MODULES_DIR)
+install: compile $(TARGET_MODULES_DIR) $(KERNEL_IPKG)
rm -rf $(LINUX_BUILD_DIR)/root*
cp -a $(BUILD_DIR)/root $(LINUX_BUILD_DIR)/
echo -e 'dest root /\noption offline_root $(LINUX_BUILD_DIR)/root' > $(LINUX_BUILD_DIR)/ipkg.conf
diff --git a/target/linux/linux-2.4/config/brcm.modules b/target/linux/linux-2.4/config/brcm.modules
new file mode 100644
index 0000000000..e717eae577
--- /dev/null
+++ b/target/linux/linux-2.4/config/brcm.modules
@@ -0,0 +1,2 @@
+et
+wl
diff --git a/target/linux/rules.mk b/target/linux/rules.mk
index be10370cf6..451ec26e42 100644
--- a/target/linux/rules.mk
+++ b/target/linux/rules.mk
@@ -24,5 +24,3 @@ $$(PKG_$(1)): $(LINUX_DIR)/.modules_done
$(IPKG_BUILD) $$(I_$(1)) $(PACKAGE_DIR)
endef
-
-
'/openwrt.git/commit/package/iproute2?h=fast2504n-3.10.26&id=2468e2c1046d01238b9931c65424d1c461b46919'>revert iproute2 to the old version until the new one is fixed (#3026)nbd 2008-01-08md5sum was left outpavlov 2008-01-08updated iproute2 to 2.6.23 + latest debian patches + latest esfq. deleted pat...pavlov 2007-09-07move package description to a separate definition, remove it when DESCRIPTION...nico 2007-06-13Fix compilation on 2.4 kernelsflorian 2007-06-13Add esfq to iproute2 and 2.4 kernel (#1891)florian 2007-06-09update iproute2 to 2.6.20-070313, and package genl utilitynoz 2007-06-04refresh all package patches in the buildroot using quiltnbd 2007-05-07Patch to work arounf flex issues with newer version of flex with somehcg 2007-04-08Fix MacOSX build errors with iproute2 (#1533)florian 2007-03-16add file type autodetection for the unpack command and nuke PKG_CAT:= in lots...nbd 2007-03-16add a default for PKG_BUILD_DIR and PKG_INSTALL_DIR (will use KERNEL_BUILD_DI...nbd