diff options
author | luka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2013-10-17 15:45:41 +0000 |
---|---|---|
committer | luka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73> | 2013-10-17 15:45:41 +0000 |
commit | 4511c244aab731c598d9d6ddbd214db14da535a0 (patch) | |
tree | 83c6e4f2c16678e9e4411bb468700ed163c6a475 | |
parent | 17f78a18b499fe701dc656befcacbd9d50434c06 (diff) |
build: drop FIT option until we actually need it
Signed-off-by: Luka Perkov <luka@openwrt.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38439 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r-- | Config.in | 9 | ||||
-rwxr-xr-x | scripts/metadata.pl | 1 | ||||
-rw-r--r-- | target/Config.in | 3 | ||||
-rw-r--r-- | target/linux/imx6/Makefile | 2 |
4 files changed, 1 insertions, 14 deletions
@@ -189,15 +189,6 @@ menu "Target Images" Include the device tree blob file(s) in the rootfs. Typically the DTBs are placed below /boot. - comment "Image Type" - - config TARGET_IMAGE_FIT - bool "FIT image with kernel and DTB" - default y if USES_FIT - depends on USES_FIT - help - Create a u-boot FIT image containing kernel and DTB - endmenu menu "Global build settings" diff --git a/scripts/metadata.pl b/scripts/metadata.pl index 04fa827c64..ddcf50bf32 100755 --- a/scripts/metadata.pl +++ b/scripts/metadata.pl @@ -172,7 +172,6 @@ sub target_config_features(@) { /targz/ and $ret .= "\tselect USES_TARGZ\n"; /cpiogz/ and $ret .= "\tselect USES_CPIOGZ\n"; /ubifs/ and $ret .= "\tselect USES_UBIFS\n"; - /fit/ and $ret .= "\tselect USES_FIT\n"; /fpu/ and $ret .= "\tselect HAS_FPU\n"; /spe_fpu/ and $ret .= "\tselect HAS_SPE_FPU\n"; /ramdisk/ and $ret .= "\tselect USES_INITRAMFS\n"; diff --git a/target/Config.in b/target/Config.in index 94c10bb34d..7f694e4c8b 100644 --- a/target/Config.in +++ b/target/Config.in @@ -63,9 +63,6 @@ config USES_CPIOGZ config USES_UBIFS bool -config USES_FIT - bool - config PROFILE_KCONFIG bool diff --git a/target/linux/imx6/Makefile b/target/linux/imx6/Makefile index ef4f08fa48..4a9bc8cb3c 100644 --- a/target/linux/imx6/Makefile +++ b/target/linux/imx6/Makefile @@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk ARCH:=arm BOARD:=imx6 BOARDNAME:=Freescale i.MX 6 Series -FEATURES:=audio display gpio pcie usb usbgadget fit squashfs targz +FEATURES:=audio display gpio pcie usb usbgadget squashfs targz CPU_TYPE:=cortex-a9 CPU_SUBTYPE:=vfpv3 MAINTAINER:=Luka Perkov <luka@openwrt.org> |