summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-02 02:38:07 +0000
committerwbx <wbx@3c298f89-4303-0410-b956-a3cf2f4a3e73>2006-01-02 02:38:07 +0000
commit3c54c0f6454b062506eb276e77549e6038d5653c (patch)
tree999dc1e011d440751b850e005d92e4050426b486
parent9ce5c96cee4ea404749d2b79b949dec988dcc68f (diff)
software watchdog as kernel modul, pf ring as kernel module. saves some bytes in the default images, ideas from 22c3 talking with nbd and sven-ola
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@2801 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--openwrt/target/linux/Config.in14
-rw-r--r--openwrt/target/linux/control/kmod-ring.control6
-rw-r--r--openwrt/target/linux/control/kmod-softdog.control6
-rw-r--r--openwrt/target/linux/linux-2.4/Makefile8
-rw-r--r--openwrt/target/linux/linux-2.4/config/ar531x4
-rw-r--r--openwrt/target/linux/linux-2.4/config/ar72
-rw-r--r--openwrt/target/linux/linux-2.4/config/brcm117
-rw-r--r--openwrt/target/linux/linux-2.4/config/x862
8 files changed, 42 insertions, 117 deletions
diff --git a/openwrt/target/linux/Config.in b/openwrt/target/linux/Config.in
index 8ea02179ff..cd2c5017ac 100644
--- a/openwrt/target/linux/Config.in
+++ b/openwrt/target/linux/Config.in
@@ -177,6 +177,13 @@ config BR2_PACKAGE_KMOD_PPPOE
help
Support for PPP over Ethernet
+config BR2_PACKAGE_KMOD_RING
+ prompt "kmod-ring......................... PF Ring"
+ tristate
+ default m
+ help
+ PF Ring
+
config BR2_PACKAGE_KMOD_SCHED
prompt "kmod-sched........................ Traffic schedulers"
tristate
@@ -773,6 +780,13 @@ config BR2_PACKAGE_KMOD_LP
help
Kernel modules for line printer and parallel port support
+config BR2_PACKAGE_KMOD_SOFTDOG
+ prompt "kmod-softdog..................... software watchdog"
+ tristate
+ default m
+ help
+ Kernel modules for software watchdog driver
+
config BR2_PACKAGE_KMOD_WD1100
prompt "kmod-wd1100....................... Soekris net4801 watchdog"
tristate
diff --git a/openwrt/target/linux/control/kmod-ring.control b/openwrt/target/linux/control/kmod-ring.control
new file mode 100644
index 0000000000..bdd293e780
--- /dev/null
+++ b/openwrt/target/linux/control/kmod-ring.control
@@ -0,0 +1,6 @@
+Package: kmod-ring
+Priority: optional
+Section: sys
+Source: buildroot internal
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Description: Kernel PF ring stuff
diff --git a/openwrt/target/linux/control/kmod-softdog.control b/openwrt/target/linux/control/kmod-softdog.control
new file mode 100644
index 0000000000..88a7400572
--- /dev/null
+++ b/openwrt/target/linux/control/kmod-softdog.control
@@ -0,0 +1,6 @@
+Package: kmod-softdog
+Priority: optional
+Section: sys
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: buildroot internal
+Description: Kernel software watchdog driver
diff --git a/openwrt/target/linux/linux-2.4/Makefile b/openwrt/target/linux/linux-2.4/Makefile
index 8cdee42a9e..405d1b3ffb 100644
--- a/openwrt/target/linux/linux-2.4/Makefile
+++ b/openwrt/target/linux/linux-2.4/Makefile
@@ -102,6 +102,10 @@ $(eval $(call KMOD_template,TUN,tun,\
$(MODULES_DIR)/kernel/drivers/net/tun.o \
,CONFIG_TUN,,20,tun))
+$(eval $(call KMOD_template,RING,ring,\
+ $(MODULES_DIR)/kernel/net/ring/ring.o \
+,CONFIG_RING,,20,ring))
+
# Filtering / Firewalling
@@ -361,6 +365,10 @@ $(eval $(call KMOD_template,BLUETOOTH,bluetooth,\
$(MODULES_DIR)/kernel/drivers/bluetooth/*.o \
,CONFIG_BLUEZ))
+$(eval $(call KMOD_template,SOFTDOG,softdog,\
+ $(MODULES_DIR)/kernel/drivers/char/softdog.o \
+,CONFIG_SOFT_WATCHDOG,,95,softdog))
+
$(TARGETS): $(PACKAGE_DIR)
diff --git a/openwrt/target/linux/linux-2.4/config/ar531x b/openwrt/target/linux/linux-2.4/config/ar531x
index 5a9137de34..265b3aa949 100644
--- a/openwrt/target/linux/linux-2.4/config/ar531x
+++ b/openwrt/target/linux/linux-2.4/config/ar531x
@@ -310,7 +310,7 @@ CONFIG_NETLINK_DEV=m
CONFIG_NETFILTER=y
# CONFIG_NETFILTER_DEBUG is not set
CONFIG_FILTER=y
-CONFIG_RING=y
+CONFIG_RING=m
CONFIG_UNIX=y
CONFIG_INET=y
CONFIG_IP_MULTICAST=y
@@ -764,7 +764,7 @@ CONFIG_WATCHDOG_NOWAYOUT=y
# CONFIG_60XX_WDT is not set
# CONFIG_SC1200_WDT is not set
# CONFIG_SCx200_WDT is not set
-CONFIG_SOFT_WATCHDOG=y
+CONFIG_SOFT_WATCHDOG=m
# CONFIG_W83877F_WDT is not set
# CONFIG_WDT is not set
# CONFIG_WDTPCI is not set
diff --git a/openwrt/target/linux/linux-2.4/config/ar7 b/openwrt/target/linux/linux-2.4/config/ar7
index 829c0551ee..baddf531a8 100644
--- a/openwrt/target/linux/linux-2.4/config/ar7
+++ b/openwrt/target/linux/linux-2.4/config/ar7
@@ -801,7 +801,7 @@ CONFIG_AR7_ADAM2=y
CONFIG_WATCHDOG=y
CONFIG_WATCHDOG_NOWAYOUT=y
CONFIG_AR7_WDT=y
-# CONFIG_SOFT_WATCHDOG is not set
+CONFIG_SOFT_WATCHDOG=m
# CONFIG_SCx200 is not set
# CONFIG_SCx200_GPIO is not set
# CONFIG_AMD_PM768 is not set
diff --git a/openwrt/target/linux/linux-2.4/config/brcm b/openwrt/target/linux/linux-2.4/config/brcm
index 1813f44b7a..7c011b21d8 100644
--- a/openwrt/target/linux/linux-2.4/config/brcm
+++ b/openwrt/target/linux/linux-2.4/config/brcm
@@ -1,5 +1,5 @@
#
-# Automatically generated make config: don't edit
+# Automatically generated by make menuconfig: don't edit
#
CONFIG_MIPS=y
CONFIG_MIPS32=y
@@ -186,10 +186,6 @@ CONFIG_MTD_PARTITIONS=y
# CONFIG_MTD_CONCAT is not set
# CONFIG_MTD_REDBOOT_PARTS is not set
# CONFIG_MTD_CMDLINE_PARTS is not set
-
-#
-# User Modules And Translation Layers
-#
CONFIG_MTD_CHAR=y
CONFIG_MTD_BLOCK=y
# CONFIG_FTL is not set
@@ -254,10 +250,6 @@ CONFIG_MTD_BCM947XX=y
# CONFIG_MTD_SLRAM is not set
# CONFIG_MTD_MTDRAM is not set
# CONFIG_MTD_BLKMTD is not set
-
-#
-# Disk-On-Chip Device Drivers
-#
# CONFIG_MTD_DOC1000 is not set
# CONFIG_MTD_DOC2000 is not set
# CONFIG_MTD_DOC2001 is not set
@@ -329,7 +321,7 @@ CONFIG_NETLINK_DEV=m
CONFIG_NETFILTER=y
# CONFIG_NETFILTER_DEBUG is not set
CONFIG_FILTER=y
-CONFIG_RING=y
+CONFIG_RING=m
CONFIG_UNIX=y
CONFIG_INET=y
CONFIG_IP_MULTICAST=y
@@ -414,11 +406,11 @@ CONFIG_IP_NF_TARGET_MASQUERADE=y
CONFIG_IP_NF_TARGET_REDIRECT=m
CONFIG_IP_NF_TARGET_NETMAP=m
CONFIG_IP_NF_NAT_PPTP=m
+CONFIG_IP_NF_NAT_PROTO_GRE=m
CONFIG_IP_NF_NAT_SIP=m
CONFIG_IP_NF_NAT_H323=m
CONFIG_IP_NF_NAT_MMS=m
CONFIG_IP_NF_NAT_RTSP=m
-CONFIG_IP_NF_NAT_PROTO_GRE=m
CONFIG_IP_NF_NAT_AMANDA=m
CONFIG_IP_NF_NAT_SNMP_BASIC=m
CONFIG_IP_NF_NAT_IRC=y
@@ -445,10 +437,6 @@ CONFIG_IP_NF_ARP_MANGLE=m
CONFIG_IP_VS=m
# CONFIG_IP_VS_DEBUG is not set
CONFIG_IP_VS_TAB_BITS=12
-
-#
-# IPVS scheduler
-#
CONFIG_IP_VS_RR=m
CONFIG_IP_VS_WRR=m
CONFIG_IP_VS_LC=m
@@ -459,12 +447,7 @@ CONFIG_IP_VS_DH=m
CONFIG_IP_VS_SH=m
CONFIG_IP_VS_SED=m
CONFIG_IP_VS_NQ=m
-
-#
-# IPVS application helper
-#
CONFIG_IP_VS_FTP=m
-CONFIG_IP_VS_NFCT=y
CONFIG_IPV6=m
#
@@ -499,10 +482,6 @@ CONFIG_IP6_NF_TARGET_IMQ=m
# CONFIG_IP_SCTP is not set
# CONFIG_ATM is not set
CONFIG_VLAN_8021Q=y
-
-#
-#
-#
# CONFIG_IPX is not set
# CONFIG_ATALK is not set
# CONFIG_DECNET is not set
@@ -567,10 +546,6 @@ CONFIG_IDE=m
# IDE, ATA and ATAPI Block devices
#
CONFIG_BLK_DEV_IDE=m
-
-#
-# Please see Documentation/ide.txt for help/info on IDE drives
-#
# CONFIG_BLK_DEV_HD_IDE is not set
# CONFIG_BLK_DEV_HD is not set
# CONFIG_BLK_DEV_IDE_SATA is not set
@@ -584,10 +559,6 @@ CONFIG_IDEDISK_STROKE=y
# CONFIG_BLK_DEV_IDEFLOPPY is not set
# CONFIG_BLK_DEV_IDESCSI is not set
# CONFIG_IDE_TASK_IOCTL is not set
-
-#
-# IDE chipset support/bugfixes
-#
# CONFIG_BLK_DEV_CMD640 is not set
# CONFIG_BLK_DEV_CMD640_ENHANCED is not set
# CONFIG_BLK_DEV_ISAPNP is not set
@@ -645,20 +616,12 @@ CONFIG_BLK_DEV_PDC202XX=y
# SCSI support
#
CONFIG_SCSI=m
-
-#
-# SCSI support type (disk, tape, CD-ROM)
-#
CONFIG_BLK_DEV_SD=m
CONFIG_SD_EXTRA_DEVS=5
# CONFIG_CHR_DEV_ST is not set
# CONFIG_CHR_DEV_OSST is not set
# CONFIG_BLK_DEV_SR is not set
CONFIG_CHR_DEV_SG=m
-
-#
-# Some SCSI devices (e.g. CD jukebox) support multiple LUNs
-#
# CONFIG_SCSI_DEBUG_QUEUES is not set
CONFIG_SCSI_MULTI_LUN=y
# CONFIG_SCSI_CONSTANTS is not set
@@ -875,17 +838,9 @@ CONFIG_WL=m
# CONFIG_PLX_HERMES is not set
# CONFIG_TMD_HERMES is not set
# CONFIG_PCI_HERMES is not set
-
-#
-# Wireless Pcmcia cards support
-#
# CONFIG_PCMCIA_HERMES is not set
# CONFIG_AIRO_CS is not set
# CONFIG_PCMCIA_ATMEL is not set
-
-#
-# Prism54 PCI/PCMCIA GT/Duette Driver - 802.11(a/b/g)
-#
# CONFIG_PRISM54 is not set
CONFIG_NET_WIRELESS=y
@@ -911,10 +866,6 @@ CONFIG_SHAPER=m
# Amateur Radio support
#
CONFIG_HAMRADIO=y
-
-#
-# Packet Radio protocols
-#
CONFIG_AX25=m
# CONFIG_AX25_DAMA_SLAVE is not set
# CONFIG_NETROM is not set
@@ -923,10 +874,6 @@ CONFIG_AX25=m
#
# AX.25 network device drivers
#
-
-#
-# AX.25 network device drivers
-#
CONFIG_MKISS=m
# CONFIG_6PACK is not set
# CONFIG_BPQETHER is not set
@@ -989,14 +936,6 @@ CONFIG_PPDEV=m
# Joysticks
#
# CONFIG_INPUT_GAMEPORT is not set
-
-#
-# Input core support is needed for gameports
-#
-
-#
-# Input core support is needed for joysticks
-#
# CONFIG_QIC02_TAPE is not set
# CONFIG_IPMI_HANDLER is not set
# CONFIG_IPMI_PANIC_EVENT is not set
@@ -1023,7 +962,7 @@ CONFIG_WATCHDOG_NOWAYOUT=y
# CONFIG_60XX_WDT is not set
# CONFIG_SC1200_WDT is not set
# CONFIG_SCx200_WDT is not set
-CONFIG_SOFT_WATCHDOG=y
+CONFIG_SOFT_WATCHDOG=m
# CONFIG_W83877F_WDT is not set
# CONFIG_WDT is not set
# CONFIG_WDTPCI is not set
@@ -1228,10 +1167,6 @@ CONFIG_VIDEO_DEV=m
#
CONFIG_VIDEO_PROC_FS=y
# CONFIG_I2C_PARPORT is not set
-
-#
-# Video Adapters
-#
# CONFIG_VIDEO_BT848 is not set
# CONFIG_VIDEO_PMS is not set
# CONFIG_VIDEO_BWQCAM is not set
@@ -1290,30 +1225,14 @@ CONFIG_SOUND=m
#
CONFIG_USB=m
# CONFIG_USB_DEBUG is not set
-
-#
-# Miscellaneous USB options
-#
CONFIG_USB_DEVICEFS=y
# CONFIG_USB_BANDWIDTH is not set
-
-#
-# USB Host Controller Drivers
-#
CONFIG_USB_EHCI_HCD=m
# CONFIG_USB_UHCI is not set
CONFIG_USB_UHCI_ALT=m
CONFIG_USB_OHCI=m
-
-#
-# USB Device Class drivers
-#
CONFIG_USB_AUDIO=m
# CONFIG_USB_EMI26 is not set
-
-#
-# USB Bluetooth can only be used with disabled Bluetooth subsystem
-#
# CONFIG_USB_MIDI is not set
CONFIG_USB_STORAGE=m
# CONFIG_USB_STORAGE_DEBUG is not set
@@ -1327,15 +1246,7 @@ CONFIG_USB_STORAGE_SDDR55=y
CONFIG_USB_STORAGE_JUMPSHOT=y
CONFIG_USB_ACM=m
CONFIG_USB_PRINTER=m
-
-#
-# USB Human Interface Devices (HID)
-#
# CONFIG_USB_HID is not set
-
-#
-# Input core support is needed for USB HID input layer or HIDBP support
-#
# CONFIG_USB_HIDINPUT is not set
# CONFIG_USB_HIDDEV is not set
# CONFIG_USB_KBD is not set
@@ -1344,19 +1255,11 @@ CONFIG_USB_PRINTER=m
# CONFIG_USB_WACOM is not set
# CONFIG_USB_KBTAB is not set
# CONFIG_USB_POWERMATE is not set
-
-#
-# USB Imaging devices
-#
# CONFIG_USB_DC2XX is not set
# CONFIG_USB_MDC800 is not set
# CONFIG_USB_SCANNER is not set
# CONFIG_USB_MICROTEK is not set
# CONFIG_USB_HPUSBSCSI is not set
-
-#
-# USB Multimedia devices
-#
# CONFIG_USB_IBMCAM is not set
# CONFIG_USB_KONICAWC is not set
# CONFIG_USB_OV511 is not set
@@ -1367,20 +1270,12 @@ CONFIG_USB_PWC=m
# CONFIG_USB_VICAM is not set
# CONFIG_USB_DSBR is not set
# CONFIG_USB_DABUSB is not set
-
-#
-# USB Network adaptors
-#
# CONFIG_USB_PEGASUS is not set
# CONFIG_USB_RTL8150 is not set
# CONFIG_USB_KAWETH is not set
# CONFIG_USB_CATC is not set
# CONFIG_USB_CDCETHER is not set
# CONFIG_USB_USBNET is not set
-
-#
-# USB port drivers
-#
# CONFIG_USB_USS720 is not set
#
@@ -1408,10 +1303,6 @@ CONFIG_USB_SERIAL_PL2303=m
# CONFIG_USB_SERIAL_CYBERJACK is not set
# CONFIG_USB_SERIAL_XIRCOM is not set
# CONFIG_USB_SERIAL_OMNINET is not set
-
-#
-# USB Miscellaneous drivers
-#
# CONFIG_USB_RIO500 is not set
# CONFIG_USB_AUERSWALD is not set
# CONFIG_USB_TIGL is not set
diff --git a/openwrt/target/linux/linux-2.4/config/x86 b/openwrt/target/linux/linux-2.4/config/x86
index 728613c4a4..c378a24936 100644
--- a/openwrt/target/linux/linux-2.4/config/x86
+++ b/openwrt/target/linux/linux-2.4/config/x86
@@ -942,7 +942,7 @@ CONFIG_WATCHDOG_NOWAYOUT=y
# CONFIG_60XX_WDT is not set
CONFIG_SC1200_WDT=m
CONFIG_SCx200_WDT=m
-CONFIG_SOFT_WATCHDOG=y
+CONFIG_SOFT_WATCHDOG=m
# CONFIG_W83877F_WDT is not set
# CONFIG_WDT is not set
# CONFIG_WDTPCI is not set