summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorcyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-02 16:38:28 +0000
committercyrus <cyrus@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-10-02 16:38:28 +0000
commit2d7ad98b392d38fdb6e37af8a12ef8db272663a4 (patch)
treea3a7123ba3a7fd960d609ac83e3663c239332fa0
parent8fc410ff46ae5767ccf0f0a1f1271eeb881a82ca (diff)
package/index: fix index creating when building without signing
Signed-off-by: Alexander Couzens <lynxis@fe80.eu> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38287 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--package/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/Makefile b/package/Makefile
index bac7001c4f..f82654cf90 100644
--- a/package/Makefile
+++ b/package/Makefile
@@ -130,16 +130,16 @@ ifndef CONFIG_OPKGSMIME_PASSPHRASE
endif
$(curdir)/index: FORCE
+ @echo Generating package index...
+ @(cd $(PACKAGE_DIR); \
+ $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
+ gzip -9c Packages > Packages.gz )
ifeq ($(call qstrip,$(CONFIG_OPKGSMIME_KEY)),)
@echo Signing key has not been configured
else
ifeq ($(call qstrip,$(CONFIG_OPKGSMIME_CERT)),)
@echo Certificate has not been configured
else
- @echo Generating package index...
- @(cd $(PACKAGE_DIR); \
- $(SCRIPT_DIR)/ipkg-make-index.sh . 2>&1 > Packages && \
- gzip -9c Packages > Packages.gz )
@echo Signing package index...
@(cd $(PACKAGE_DIR); \
openssl smime -binary -in Packages.gz \