summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-07-18 11:29:18 +0000
committerjogo <jogo@3c298f89-4303-0410-b956-a3cf2f4a3e73>2013-07-18 11:29:18 +0000
commit016baa2a138cd43114401dba83f59f1a68f1eaa0 (patch)
treeabe112b5c67342ca9147f61257eca94cc64638e1
parentf82e916164a6829e5126168e73dadaa6998a8a3e (diff)
build: print missing dependency error to stderr
Allow to see the actual error even when compiling with V=w/V=1 only. Signed-off-by: Jonas Gorski <jogo@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37388 3c298f89-4303-0410-b956-a3cf2f4a3e73
-rw-r--r--include/package-ipkg.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/include/package-ipkg.mk b/include/package-ipkg.mk
index 696de156cf..522a1de15f 100644
--- a/include/package-ipkg.mk
+++ b/include/package-ipkg.mk
@@ -64,8 +64,8 @@ ifneq ($(PKG_NAME),toolchain)
echo "$$$$FILE" >> $(PKG_INFO_DIR)/$(1).missing; \
done; \
if [ -f "$(PKG_INFO_DIR)/$(1).missing" ]; then \
- echo "Package $(1) is missing dependencies for the following libraries:"; \
- cat "$(PKG_INFO_DIR)/$(1).missing"; \
+ echo "Package $(1) is missing dependencies for the following libraries:" >&2; \
+ cat "$(PKG_INFO_DIR)/$(1).missing" >&2; \
false; \
fi; \
)