brcm63xx: F@ST2504n board support (image, base-files) fast2504n-3.8
authornorly <ny-git@enpas.org>
Mon, 20 May 2013 12:54:07 +0000 (13:54 +0100)
committernorly <ny-git@enpas.org>
Fri, 14 Jun 2013 02:02:29 +0000 (03:02 +0100)
target/linux/brcm63xx/base-files/etc/uci-defaults/02_network
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/image/Makefile

index f59fed678167dd9b26dc08bf68d0963808689768..07a68abe0883f1b3c44264c05bdce2243f268c19 100755 (executable)
@@ -78,6 +78,7 @@ DVG3810BN)
 96328A-1441N1 |\
 963281TAN |\
 963281T_TEF |\
+"F@ST2504n" |\
 96368MVNgr)
        ucidef_set_interface_lan "eth0.1"
        ucidef_add_switch "eth0" "1" "1"
index ded946de6211d59c31d3ad7725f9568002e624d5..e0b00eb6157c703369a6a17b75cb5c0d2c1b42b1 100755 (executable)
@@ -117,6 +117,11 @@ brcm63xx_detect() {
                brcm63xx_has_reset_button="true"
                ifname=eth0
                ;;
+       "F@ST2504n")
+               status_led="fast2504n:green:ok"
+               brcm63xx_has_reset_button="true"
+               ifname=eth0
+               ;;
        *)
                ;;
        esac
index 69621dc5aee16ff4b4f2847b975d10daebc24a70..7ae35881dfe8a4c587d1eca3a74a5eb0099e5759 100755 (executable)
@@ -211,6 +211,9 @@ define Image/Build
        # Neufbox6
        $(call Image/Build/CFE,$(1),NB6-SER-r0,6362,NEUFBOX6,OpenWRT-$(REVISION))
 
+       # Sagem F@ST2504n
+       $(call Image/Build/CFE,$(1),F@ST2504n,6362,F@ST2504n,OpenWRT-$(REVISION))
+
   ifeq ($(CONFIG_TARGET_brcm63xx_generic),y)
        # Comtrend 6373
        $(call Image/Build/CFE,$(1),CT6373-1,6358,CT6373)