build: set owner root for all files on ubifs creation
authorluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Oct 2013 00:11:20 +0000 (00:11 +0000)
committerluka <luka@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 18 Oct 2013 00:11:20 +0000 (00:11 +0000)
When creating an image it makes no sense to have files owned by
the uid and gid on the host (and even creates a bug when for
example dropbear authorized_keys is included via env/files).

Signed-off-by: Joris de Vries <joris@apptrician.nl>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@38442 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk

index 729929f9da1ca91bc5a997af813d8c680ee7e9f6..c7da0600c3376b82d0e8d6e985e23d22880e3dc0 100644 (file)
@@ -139,6 +139,7 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
                        $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_LZO),--force-compr=lzo) \
                        $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_ZLIB),--force-compr=zlib) \
                        --jrn-size=$(CONFIG_TARGET_UBIFS_JOURNAL_SIZE) \
+                       --squash-uids \
                        -o $(KDIR)/root.ubifs \
                        -d $(TARGET_DIR)
         endif