dropbear: move options.h editing to Build/Configure
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 29 Mar 2014 17:10:52 +0000 (17:10 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 29 Mar 2014 17:10:52 +0000 (17:10 +0000)
fixes incremental build with change to CONFIG_DROPBEAR_ECC
drop --with-shared which is unknown to configure

Patch by Catalin Patulea <cat@vv.carleton.ca>

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@40300 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/network/services/dropbear/Makefile

index 692199e8aa35939ac193ac0cb7f2c4ed975cf926..b2bd8cc6050bc033ae4bf73cff767b10de30a9b4 100644 (file)
@@ -59,7 +59,6 @@ define Package/dropbearconvert
 endef
 
 CONFIGURE_ARGS += \
-       --with-shared \
        --disable-pam \
        --enable-openpty \
        --enable-syslog \
@@ -78,8 +77,9 @@ CONFIGURE_ARGS += \
 TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections
 TARGET_LDFLAGS += -Wl,--gc-sections
 
-define Build/Prepare
-       $(call Build/Prepare/Default)
+define Build/Configure
+       $(Build/Configure/Default)
+
        # Enforce that all replacements are made, otherwise options.h has changed
        # format and this logic is broken.
        for OPTION in DROPBEAR_ECDSA DROPBEAR_ECDH DROPBEAR_CURVE25519; do \